Bug 861945 - if replace-brick is running , it shouldn't allow geo-rep to start.
if replace-brick is running , it shouldn't allow geo-rep to start.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.0
x86_64 Linux
high Severity low
: ---
: ---
Assigned To: Venky Shankar
Vijaykumar Koppad
:
Depends On:
Blocks: 872289
  Show dependency treegraph
 
Reported: 2012-10-01 08:25 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.4rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 872289 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-10-01 08:25:59 EDT
Description of problem: Currently, if there is a geo-rep session going on , we don't allow replace-brick to start or do any replace-brick operations. Similarly , we shouldn't allow geo-rep to start if there is a replace-brick going on. 


Version-Release number of selected component (if applicable):
3.3.0rhs-28.el6rhs.x86_64

How reproducible: Always 


Steps to Reproduce:
1.Create a volume, lets say distribute-volume, 
2.Create fair amount of data on the mount point.
3.Start replace-brick of one of the volume 
4.Before repace-brick commit, try to start geo-rep. 
  
Actual results: It allow geo-rep to start


Expected results: IT shouldn't allow replace-brick to start 


Additional info:
Comment 2 Vijay Bellur 2012-12-11 19:27:04 EST
CHANGE: http://review.gluster.org/4289 (gsyncd / geo-rep: do not start geo-rep if replace brick is in progress) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Vijaykumar Koppad 2013-07-31 05:27:36 EDT
Verified on 3.4.0.14rhs-1.el6rhs.x86_64
Comment 4 Scott Haines 2013-09-23 18:38:38 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:27 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.