This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 86211 - Installer Crashes citing /usr/lib/anaconda/gui.py as reason
Installer Crashes citing /usr/lib/anaconda/gui.py as reason
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-17 05:38 EST by Ranganath P. Kashyap.
Modified: 2007-04-18 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 05:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ranganath P. Kashyap. 2003-03-17 05:38:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
traceback(most recent call last)

file "/usr/lib/anaconda/gui.py", line 786,in
handleRenderCallbackself.CurrentWindow.renderCallback()

file "/usr/lib/anaconda/iw/progress.gui.py",line 149, in 
renderCallbackself.icw.nextclicked()

file "/usr/lib/anaconda/gui.py", line 632 , in 
nextClickedself.dispatch.gotonext()

file "/usr/lib/anaconda/dispatch.py", line 150, in 
gotoNextself.moveStep()

file "/usr/lib/anaconda/dispatch.py", line 215, in 
MoveStep.rc=apply(func,self.bindArgs(args))

file "/usr/lib/anaconda/packages.py", line 430, in 
turnOnFilesystemspartitions.doMetaDeletes(diskset)

file "/usr/lib/anaconda/partitions.py",line 1110, in 
doMetaDeleteslvm.vgactivate()

file "/usr/lib/anaconda/lvm.py", line 54, in vgactivate 
searchPath=1)

file "/usr/lib/anaconda/iutil.py", line 66, in 
execWithRedirectchildpid=os.fork()

OSError: [Errno 12] cannot allocate memory


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.try installing(on my machine though;-)
2.
3.
    

Actual Results:  installer crashes

Expected Results:  installer should proceed normally

Additional info:
Comment 1 Michael Fulbright 2003-03-17 14:24:25 EST
How much RAM does your system have?
Comment 2 Ranganath P. Kashyap. 2003-03-18 00:30:54 EST
System Info:-
P3 - 500MHz
Intel810 MotherBoard
64MB RAM (I was able to install Psyche on another s/m with 64MB RAM)
20GB HDD (with first partition for linux)

anything else?
Comment 3 Michael Fulbright 2003-03-21 10:58:44 EST
I would recommend at least 128MB (192MB wouldn't hurt) of swap for this system.
How much were you using when the error occurred?
Comment 4 Ranganath P. Kashyap. 2003-03-27 05:31:28 EST
i was using 128MB! the partitioning on the 20Gig disk was like 
first partition Ext2 3.5GB (Created using PartitionMagic)
second partition swap 128MB (Created using PartitionMagic)
third partition FAT32
fouth partition FAT32
fifth partition FAT32
Comment 5 Michael Fulbright 2003-04-02 15:23:17 EST
Then probably you need to try 192MB of swap.
Comment 6 Ranganath P. Kashyap. 2003-04-04 00:01:29 EST
do you think that is all the problem? how about the partitioning? am i doing it 
right?
Comment 7 Michael Fulbright 2003-04-04 16:18:14 EST
I would recommend creating a swap partition of at least 192MB.
Comment 8 Ranganath P. Kashyap. 2003-04-14 00:21:39 EDT
hi,
i tried using 256MB swap space; but that didn't help either!
regards,
-kashyap.
Comment 9 Trev 2003-04-18 19:56:59 EDT
Hi, I just tried it on a system with 48MB RAM and got the same error, but when 
I did a text-only installation, it worked fine.

I don't think it has any relation to the swap, as it crashed *before* creating 
the swap partition! Must be a bug with 8.0 - the 7.3 install worked fine for me.
Comment 10 Michael Fulbright 2003-05-12 17:21:09 EDT
Usually 128MB is enough for the graphical install to start up and work. You need
the extra swap for upgrades usually since these take more RAM to process than a
fresh install.

Try booting with 'linux text' on the command line.
Comment 11 Ranganath P. Kashyap. 2003-05-21 05:50:44 EDT
it worked for me. thanks a lot
regards,
kashyap

Note You need to log in before you can comment on or make changes to this bug.