Bug 862143 - bkr client spits warning during TAB completion
bkr client spits warning during TAB completion
Status: CLOSED DUPLICATE of bug 856691
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-01 23:24 EDT by Amit Saha
Modified: 2018-02-05 19:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 23:34:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2012-10-01 23:24:32 EDT
Description of problem:

When the BASH completion facility (https://bugzilla.redhat.com/show_bug.cgi?id=856691) is attempted to be used, 'bkr' spits out warning regarding the config file being not found. For example, I type 'bkr jo <TAB>' and you see the warning and then all the BASH completion options.

$ bkr jo/home/bne/asaha/.beaker_client/config not found, using /etc/beaker/client.conf
b-/home/bne/asaha/.beaker_client/config not found, using /etc/beaker/client.conf
/home/bne/asaha/.beaker_client/config not found, using /etc/beaker/client.conf

job-cancel   job-delete   job-logs     job-results  job-watch    
job-clone    job-list     job-modify   job-submit   


Version-Release number of selected component (if applicable):



How reproducible:

Always. 

Steps to Reproduce:
1.Install the BASH completion scripts
2. See above description.
3.
  
Actual results:

See above.

Expected results:

Warnings should be after the job completion options have been shown if at all. However, IMO, no warnings should be shown in this case at all, since a command has not yet been executed. 


Additional info:
Comment 1 Dan Callaghan 2012-10-01 23:34:05 EDT

*** This bug has been marked as a duplicate of bug 856691 ***

Note You need to log in before you can comment on or make changes to this bug.