Bug 862150 - SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on the sock_file system_bus_socket.
SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on...
Status: CLOSED DUPLICATE of bug 859782
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:485477300e4b62a272dd099081b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 00:11 EDT by D. Charles Pyle
Modified: 2012-10-02 04:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 04:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-02 00:11 EDT, D. Charles Pyle
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-02 00:11 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-10-02 00:11:22 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on the sock_file system_bus_socket.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mission-control-5 should be allowed write access on the system_bus_socket sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:system_dbusd_var_run_t:s0
:Target Objects                system_bus_socket [ sock_file ]
:Source                        mission-control
:Source Path                   /usr/libexec/mission-control-5
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           telepathy-mission-control-5.13.2-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-25.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    2012-09-30 12:50:04 MDT
:Last Seen                     2012-10-01 16:37:27 MDT
:Local ID                      6d95c3e0-5355-4143-aa65-7e4b1bdba4b9
:
:Raw Audit Messages
:type=AVC msg=audit(1349131047.45:138): avc:  denied  { write } for  pid=3465 comm="mission-control" name="system_bus_socket" dev="tmpfs" ino=14202 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:system_dbusd_var_run_t:s0 tclass=sock_file
:
:
:type=AVC msg=audit(1349131047.45:138): avc:  denied  { connectto } for  pid=3465 comm="mission-control" path="/run/dbus/system_bus_socket" scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=unix_stream_socket
:
:
:type=SYSCALL msg=audit(1349131047.45:138): arch=x86_64 syscall=connect success=yes exit=0 a0=5 a1=7fff51af6410 a2=21 a3=6e75722f7261762f items=0 ppid=1 pid=3465 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=3 comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mission-control,xdm_dbusd_t,system_dbusd_var_run_t,sock_file,write
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t system_dbusd_t:unix_stream_socket connectto;
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t system_dbusd_var_run_t:sock_file write;
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t system_dbusd_t:unix_stream_socket connectto;
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t system_dbusd_var_run_t:sock_file write;
:
Comment 1 D. Charles Pyle 2012-10-02 00:11:24 EDT
Created attachment 620116 [details]
File: type
Comment 2 D. Charles Pyle 2012-10-02 00:11:26 EDT
Created attachment 620117 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-02 04:47:42 EDT

*** This bug has been marked as a duplicate of bug 859782 ***

Note You need to log in before you can comment on or make changes to this bug.