This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 862151 - SELinux is preventing /usr/libexec/mission-control-5 from 'remove_name' accesses on the directory accounts-goa.cfg.C8UELW.
SELinux is preventing /usr/libexec/mission-control-5 from 'remove_name' acces...
Status: CLOSED DUPLICATE of bug 862156
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d472a8661e18ee342ee7bbeb253...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 00:11 EDT by D. Charles Pyle
Modified: 2012-10-02 04:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 04:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-02 00:12 EDT, D. Charles Pyle
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-02 00:12 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-10-02 00:11:57 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/libexec/mission-control-5 from 'remove_name' accesses on the directory accounts-goa.cfg.C8UELW.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mission-control-5 should be allowed remove_name access on the accounts-goa.cfg.C8UELW directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:xdm_var_lib_t:s0
:Target Objects                accounts-goa.cfg.C8UELW [ dir ]
:Source                        mission-control
:Source Path                   /usr/libexec/mission-control-5
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           telepathy-mission-control-5.13.2-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-25.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    2012-09-30 12:50:04 MDT
:Last Seen                     2012-10-01 16:37:27 MDT
:Local ID                      8a1169a3-bfea-4c14-9cf1-721457bef59e
:
:Raw Audit Messages
:type=AVC msg=audit(1349131047.38:137): avc:  denied  { remove_name } for  pid=3465 comm="mission-control" name="accounts-goa.cfg.C8UELW" dev="dm-1" ino=2367378 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1349131047.38:137): avc:  denied  { rename } for  pid=3465 comm="mission-control" name="accounts-goa.cfg.C8UELW" dev="dm-1" ino=2367378 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file
:
:
:type=AVC msg=audit(1349131047.38:137): avc:  denied  { unlink } for  pid=3465 comm="mission-control" name="accounts-goa.cfg" dev="dm-1" ino=2365724 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349131047.38:137): arch=x86_64 syscall=rename success=yes exit=0 a0=a3b320 a1=a49bb0 a2=3e7c3b1768 a3=6f6363612f6c6f72 items=0 ppid=3464 pid=3465 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=3 comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mission-control,xdm_dbusd_t,xdm_var_lib_t,dir,remove_name
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t xdm_var_lib_t:dir remove_name;
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t xdm_var_lib_t:file { rename unlink };
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t xdm_var_lib_t:dir remove_name;
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t xdm_var_lib_t:file { rename unlink };
:
Comment 1 D. Charles Pyle 2012-10-02 00:12:02 EDT
Created attachment 620118 [details]
File: type
Comment 2 D. Charles Pyle 2012-10-02 00:12:04 EDT
Created attachment 620119 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-02 04:29:52 EDT

*** This bug has been marked as a duplicate of bug 862156 ***

Note You need to log in before you can comment on or make changes to this bug.