Bug 862155 - SELinux is preventing /usr/libexec/mission-control-5 from 'read' accesses on the file accounts-goa.cfg.
SELinux is preventing /usr/libexec/mission-control-5 from 'read' accesses on ...
Status: CLOSED DUPLICATE of bug 862156
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b7ce1713ed0714d960a881bf276...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 00:13 EDT by D. Charles Pyle
Modified: 2012-10-02 04:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 04:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-02 00:13 EDT, D. Charles Pyle
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-02 00:13 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-10-02 00:13:22 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/libexec/mission-control-5 from 'read' accesses on the file accounts-goa.cfg.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that mission-control-5 should be allowed read access on the accounts-goa.cfg file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:xdm_var_lib_t:s0
:Target Objects                accounts-goa.cfg [ file ]
:Source                        mission-control
:Source Path                   /usr/libexec/mission-control-5
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           telepathy-mission-control-5.13.2-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-25.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    2012-09-30 12:50:04 MDT
:Last Seen                     2012-10-01 16:37:26 MDT
:Local ID                      9a389028-1bd4-44e6-b54a-0507fdd97a82
:
:Raw Audit Messages
:type=AVC msg=audit(1349131046.824:134): avc:  denied  { read } for  pid=3465 comm="mission-control" name="accounts-goa.cfg" dev="dm-1" ino=2365724 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file
:
:
:type=AVC msg=audit(1349131046.824:134): avc:  denied  { open } for  pid=3465 comm="mission-control" path="/var/lib/gdm/.local/share/telepathy/mission-control/accounts-goa.cfg" dev="dm-1" ino=2365724 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349131046.824:134): arch=x86_64 syscall=open success=yes exit=E2BIG a0=a49bb0 a1=0 a2=0 a3=0 items=0 ppid=3464 pid=3465 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=3 comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: mission-control,xdm_dbusd_t,xdm_var_lib_t,file,read
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t xdm_var_lib_t:file { read open };
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow xdm_dbusd_t xdm_var_lib_t:file { read open };
:
Comment 1 D. Charles Pyle 2012-10-02 00:13:24 EDT
Created attachment 620125 [details]
File: type
Comment 2 D. Charles Pyle 2012-10-02 00:13:26 EDT
Created attachment 620126 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-02 04:29:20 EDT

*** This bug has been marked as a duplicate of bug 862156 ***

Note You need to log in before you can comment on or make changes to this bug.