Bug 862169 - kde-runtime-libs-4.9.2 is missing kio_smb
kde-runtime-libs-4.9.2 is missing kio_smb
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-runtime (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 03:12 EDT by Sandro Mani
Modified: 2012-10-02 10:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-02 10:06:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2012-10-02 03:12:13 EDT
Description of problem:
kde-runtime-libs-4.9.2 is missing kio_smb, used to be there in <= 4.9.1

Version-Release number of selected component (if applicable):
kde-runtime-libs-4.9.2-1.fc19.x86_64
  
Actual results:
Dolphin does not know the smb protocol
Comment 1 Sandro Mani 2012-10-02 03:44:19 EDT
[...]
DEBUG: -- The following OPTIONAL packages could NOT be located on your system.
DEBUG: -- Consider installing them to enable more features from this software.
DEBUG: -----------------------------------------------------------------------------
DEBUG:    * QNtrack  <http://launchpad.net/ntrack>
DEBUG:      Network status tracking library
DEBUG:      Provides data input for Solid network status
DEBUG:    * Samba  <http://www.samba.org>
DEBUG:      the SMB client library, a version with smbc_set_context() and smbc_option_set()
DEBUG:      Needed to build the SMB kioslave
[...]


-> I guess the problem is that libsmbclient.h moved from /usr/include to /usr/include/samba-4.0, and that the FindSamba cmake script in kdelibs-devel does not find it.
Comment 2 Rex Dieter 2012-10-02 08:20:59 EDT
Should hopefully be fixed with kdelibs-4.9.2-3 + kde-runtime-4.9.2-2 builds underway,
http://koji.fedoraproject.org/koji/taskinfo?taskID=4550144
Comment 3 Sandro Mani 2012-10-02 10:06:35 EDT
Works with the new builds, thanks!

Note You need to log in before you can comment on or make changes to this bug.