Bug 862176 - Stopping an already stopped myproxy-server returns an error
Stopping an already stopped myproxy-server returns an error
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: myproxy (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Traylen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 03:47 EDT by Mattias Ellert
Modified: 2013-08-09 05:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 05:54:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2012-10-02 03:47:00 EDT
Description of problem:

Stopping an already stopped service returns an error instead of "myproxy-server already stopped [OK]"

[root@globus ~]# service myproxy-server start
Starting myproxy-server:                                   [  OK  ]
[root@globus ~]# service myproxy-server stop
Stopping myproxy-server:                                   [  OK  ]
[root@globus ~]# service myproxy-server stop
Stopping myproxy-server:                                   [FAILED]

Version-Release number of selected component (if applicable):
myproxy-5.8-1.el6

How reproducible:
Always

Steps to Reproduce:
See above
Comment 1 Mattias Ellert 2013-08-09 05:54:34 EDT
Investigating more closely, it turns out it only says it fails, but it does in fact return success (return code 0).

[root@grid ~]# service myproxy-server stop
Stopping myproxy-server:                                   [FAILED]
[root@grid ~]# echo $?
0

So this is not really a bug, just a confusing statement written on the screen.

Other services using the same killproc function from /etc/initd.d/functions shows the same behaviour, e.g. httpd:

[root@grid ~]# service httpd stop
Stopping httpd:                                            [FAILED]
[root@grid ~]# echo $?
0

So not a bug in the myproxy-server package - if at all. Closing.

Note You need to log in before you can comment on or make changes to this bug.