Bug 862194 - Correct samba4 spec file for RHEL6 support and DC-enabled builds
Correct samba4 spec file for RHEL6 support and DC-enabled builds
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba4 (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Andreas Schneider
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 05:10 EDT by Giuseppe Ragusa
Modified: 2013-03-30 04:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 11:40:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec patch versus latest (140.rc1) package release. (7.52 KB, patch)
2012-10-02 05:10 EDT, Giuseppe Ragusa
no flags Details | Diff
Proposed DC SysVinit control script. (1.74 KB, text/plain)
2012-10-02 05:12 EDT, Giuseppe Ragusa
no flags Details
smbprint script from Fedora package. (2.24 KB, text/plain)
2012-10-02 05:12 EDT, Giuseppe Ragusa
no flags Details
Spec patch versus latest RHEL6-compatible (140.rc1) package release. (10.05 KB, patch)
2012-10-05 12:19 EDT, Giuseppe Ragusa
no flags Details | Diff
Spec patch versus latest RHEL6-compatible (140.rc1) package release. (19.78 KB, patch)
2012-10-18 03:41 EDT, Giuseppe Ragusa
no flags Details | Diff

  None (edit)
Description Giuseppe Ragusa 2012-10-02 05:10:46 EDT
Created attachment 620195 [details]
Spec patch versus latest (140.rc1) package release.

Description of problem:

The latest Fedora rawhide samba4 package that included RHEL6 support (release 140.rc1) still needs some tweaks to correctly install under RHEL6:

1) the move to a "volatile" /var/run under /run (and the associated tmpfiles.d mechanism) happened in Fedora 15 and won't appear in RHEL until 7.0 (henceforth the need to conditionally modify the various references to /var/run and /run and the including of tmpfiles.d/* support files)

2) SysVinit control scripts usually have 755 permissions, sometimes 555, but never 644 except for "include-style" support files (henceforth the need to modify the install permissions)

Furthermore full AD DC support (which cannot be enabled by default for builtin Kerberos library ABI compatibility problems) if manually enabled inside spec file still lacks SysVinit/Systemd control scripts/units and post/postun/preun scriptlets.

Version-Release number of selected component (if applicable):

samba4-4.0.0-140.rc1 (as latest Fedora Rawhide package containing support for RHEL6)

Maybe a more recent reference source package will become available at RHEL6.4 official beta announcement time (I will rebase patches to that asap).

How reproducible:
Rebuild stock samba4-4.0.0-140.rc1 source package (you need newer tdb/talloc/tevent which will be arguably released with RHEL6.4) and try to install under RHEL6 (try with manually enabled full AD DC support too, but only on a limited scope, DC-only virtual/physical server with no other samba-linked packages/libraries installed).

Steps to Reproduce:
1. rpmbuild --rebuild samba4-4.0.0-140.rc1.src.rpm
2. yum localinstall samba4*
3. ...
  
Actual results:
Inconsistent references to /run and tmpfiles.d
No samba init script and no post/preun/postun actions if enabling full AD DC support.

Expected results:
RHEL6 standard/conventions followed.
AD DC reasonably integrated, if manually compiled in.

Additional info:

Originally discussed in bug 834603

Patch versus samba4-4.0.0-140.rc1 spec file provided.
Samba init scripts (from Samba Wiki, partially modified) included.
Added smbprint support and lib{wb,smb}client tweaks from latest (Fedora >= 18 only) package.
Building DC parts forces lib{wb,smb}client as standalone packages since Samba3x uses incompatible protocol (as per samba-technical discussions).
Comment 1 Giuseppe Ragusa 2012-10-02 05:12:05 EDT
Created attachment 620197 [details]
Proposed DC SysVinit control script.
Comment 2 Giuseppe Ragusa 2012-10-02 05:12:46 EDT
Created attachment 620198 [details]
smbprint script from Fedora package.
Comment 4 Giuseppe Ragusa 2012-10-05 12:19:24 EDT
Created attachment 622292 [details]
Spec patch versus latest RHEL6-compatible (140.rc1) package release.

Added mods tracking latest Fedora rawhide package release (150.rc2).
Comment 5 Giuseppe Ragusa 2012-10-18 03:41:51 EDT
Created attachment 629223 [details]
Spec patch versus latest RHEL6-compatible (140.rc1) package release.

Updating patch to latest (158.rc3) Fedora Rawhide package contents.
Obsoleting smbprint script too, since it (like samba source patches) can be taken directly from latest Fedora Rawhide package.
Comment 6 Andreas Schneider 2012-10-23 11:40:12 EDT
We cannot support a Heimdal Samba build in RHEL. If Samba will get full MIT Kerberos support we will support the DC components in a future RHEL version.

Note You need to log in before you can comment on or make changes to this bug.