Bug 862245 - pass proxy option to command line
pass proxy option to command line
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: mock (Show other bugs)
el6
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 08:30 EDT by Lameire Alexis
Modified: 2014-11-18 13:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 13:44:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lameire Alexis 2012-10-02 08:30:00 EDT
This is a feature request to mock.
today it's possible to set the proxy globaly into the configuration file /etc/mock/site-defaults.cfg by setting the config_opts['http_proxy']

Unfortunently on computer without root privilage this can't be modified and the option don't set. In this cas i should be a good idea to add an option --override-config-opt=key:value to solve this case.
Comment 1 Miroslav Suchý 2014-11-18 13:44:15 EST
This can be done (since mock-1.2.0):
cp /etc/mock/fedora-20-x86_64.cfg ./
echo "config_opts['http_proxy']=...." > ./fedora-20-x86_64.cfg
mock -r ./fedora-20-x86_64.cfg foo.src.rpm

or you can use:
       --configdir=CONFIGDIR
              Change directory where config files are found

Note You need to log in before you can comment on or make changes to this bug.