Bug 862304 - [abrt] samba-winbind-clients-4.0.0-151.fc19.rc2: smb_panic_default: Process /usr/bin/ntlm_auth was killed by signal 6 (SIGABRT)
[abrt] samba-winbind-clients-4.0.0-151.fc19.rc2: smb_panic_default: Process /...
Status: CLOSED DUPLICATE of bug 906182
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
abrt_hash:37be9be8361777caa278cc3d451...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 11:04 EDT by Erik van Pienbroek
Modified: 2013-02-07 11:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 11:35:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (866 bytes, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: environ (3.10 KB, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: backtrace (13.99 KB, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: cgroup (127 bytes, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: maps (34.94 KB, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: dso_list (7.63 KB, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: build_ids (3.24 KB, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: open_fds (331 bytes, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details
File: var_log_messages (716 bytes, text/plain)
2012-10-02 11:05 EDT, Erik van Pienbroek
no flags Details

  None (edit)
Description Erik van Pienbroek 2012-10-02 11:04:58 EDT
Description of problem:
Authenticating against an Microsoft Exchange mail server using Microsoft Outlook 2007 (Wine)

Version-Release number of selected component:
samba-winbind-clients-4.0.0-151.fc19.rc2

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        ntlm_auth --helper-protocol=ntlmssp-client-1 --username=erik.vanpienbroek --domain=PRORAILNL
crash_function: smb_panic_default
kernel:         3.6.0-0.rc7.git0.1.fc18.x86_64

truncated backtrace:
:Thread no. 1 (7 frames)
: #2 smb_panic_default at ../lib/util/fault.c:149
: #3 smb_panic at ../lib/util/fault.c:162
: #4 fault_report at ../lib/util/fault.c:77
: #5 sig_fault at ../lib/util/fault.c:88
: #7 manage_gensec_request at ../source4/utils/ntlm_auth.c:628
: #8 manage_squid_request at ../source4/utils/ntlm_auth.c:1012
: #9 squid_stream at ../source4/utils/ntlm_auth.c:1023
Comment 1 Erik van Pienbroek 2012-10-02 11:05:01 EDT
Created attachment 620332 [details]
File: core_backtrace
Comment 2 Erik van Pienbroek 2012-10-02 11:05:03 EDT
Created attachment 620333 [details]
File: environ
Comment 3 Erik van Pienbroek 2012-10-02 11:05:07 EDT
Created attachment 620334 [details]
File: backtrace
Comment 4 Erik van Pienbroek 2012-10-02 11:05:09 EDT
Created attachment 620335 [details]
File: limits
Comment 5 Erik van Pienbroek 2012-10-02 11:05:11 EDT
Created attachment 620336 [details]
File: cgroup
Comment 6 Erik van Pienbroek 2012-10-02 11:05:14 EDT
Created attachment 620337 [details]
File: maps
Comment 7 Erik van Pienbroek 2012-10-02 11:05:16 EDT
Created attachment 620338 [details]
File: dso_list
Comment 8 Erik van Pienbroek 2012-10-02 11:05:18 EDT
Created attachment 620339 [details]
File: build_ids
Comment 9 Erik van Pienbroek 2012-10-02 11:05:20 EDT
Created attachment 620340 [details]
File: open_fds
Comment 10 Erik van Pienbroek 2012-10-02 11:05:22 EDT
Created attachment 620341 [details]
File: var_log_messages
Comment 11 Erik van Pienbroek 2012-10-03 15:19:32 EDT
Additional information:
When I rename the /usr/bin/ntlm_auth3 binary to /usr/bin/ntlm_auth (which is also provided by the same package) then the segfault doesn't occur and MS Outlook works fine
Comment 12 Alexander Bokovoy 2012-10-03 15:24:30 EDT
Thanks.

We are going to remove source4/utils/ntlm_auth.c upstream since winbindd from source4/ is not built and ntlm_auth should be synchronized with winbindd version (source4 should use source4, source3 -- source3).
Comment 13 austinenglish 2013-02-03 05:05:34 EST
Running wine's test suite. To reproduce, download/compile wine,  then:
$ cd $WINESRC/dlls/secur32/tests
$ make ntlm.ok


backtrace_rating: 4
Package: samba-winbind-clients-4.0.0-168.fc18.rc5
OS Release: Fedora release 18 (Spherical Cow)
Comment 14 Andreas Schneider 2013-02-04 11:13:24 EST
This sounds like bug #906182. We don't parse the PAC correctly.
Comment 15 Andreas Schneider 2013-02-07 11:35:33 EST

*** This bug has been marked as a duplicate of bug 906182 ***

Note You need to log in before you can comment on or make changes to this bug.