Bug 862329 - Javascript date error
Javascript date error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 12:25 EDT by Ian G. Gosling
Modified: 2013-08-29 09:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 09:11:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian G. Gosling 2012-10-02 12:25:26 EDT
Description of problem:

Some dates are not constructed/displayed properly.

Version-Release number of selected component (if applicable):

firefox-10.0.7-1.el6_3

How reproducible:
always

Steps to Reproduce:
1. Create a web page containing the following javascript code

date1 = new Date(2012, 9, d);
alert(date1.getDate());

for various values of d.

2. Browse to the web page using Firefox.
  
Actual results:
d   alert message
26  26
27  27
28  27
29  30
30  31

Expected results:
alert = d for all values of d

Additional info:
none
Comment 2 Ian G. Gosling 2012-10-02 12:38:31 EDT
Timezone is Europe/London, so daylight savings ends at 03:00 Oct 28 2012.
Comment 3 RHEL Product and Program Management 2012-12-14 03:04:03 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Martin Stransky 2013-08-29 09:11:32 EDT
Seems to be fixed in new versions (at least Firefox-23.0.1). The fix will hit RHEL sooner or later with new firefox versions. We're not going to ship a special fix for RHEL, so closing as WONTFIX for now.

Note You need to log in before you can comment on or make changes to this bug.