Bug 862351 - auotinstall fails to complete due to being terminated
auotinstall fails to complete due to being terminated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 13:19 EDT by Joey Boggs
Modified: 2013-02-28 11:31 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Bug Fix
Doc Text:
During installation, ovirt-auto-install attempts to stop all processes that are using the log directory before unmounting. The ovirt-auto-install process falls into that list, terminating itself.  This is because ovirt-auto-install has files open  in the /var/log that are closed before unmounting the directory.  This fix directs ovirt-auto-install not to kill it's own processes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:31:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 haiyang,dong 2012-10-30 00:09:54 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

auto install completes successfully, so the issue about "auotinstall fails to complete due to being terminated " has been fixed, change the status into "VERIFIED"

but found another issue in the link patch of comment 1 , have report bug 871242 to track the issue "function "unmount_logging_services" only stop the first one of the list services which keep /var/log busy"
Comment 4 haiyang,dong 2012-12-26 21:05:08 EST
re-test on version rhev-hypervisor6-6.4-20121212.1.el6 , auto install completes successfully, so the issue about "auotinstall fails to complete due to being terminated " was fixed on it.
Comment 6 errata-xmlrpc 2013-02-28 11:31:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.