Bug 862389 - A Vinagre VNC session will only display 800x600 guest
A Vinagre VNC session will only display 800x600 guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vinagre (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: 7.1
Assigned To: Marek Kašík
Desktop QE
: Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 14:59 EDT by Bill Sanford
Modified: 2015-03-05 05:24 EST (History)
3 users (show)

See Also:
Fixed In Version: vinagre-3.8.2-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 05:24:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 628006 None None None 2012-10-02 15:02:24 EDT

  None (edit)
Description Bill Sanford 2012-10-02 14:59:09 EDT
Description of problem:
When using RHEL7 and vinagre, the RDP session that is connected will only display the guest at an 800x600 resolution (Minimum resolution). There is no way to change it on the client or guest. 

There is already a bug upstream about this. I will have an external link to the bug

Version-Release number of selected component (if applicable):
RHEL-7.0-20120711.2
vinagre-3.4.2-1.el7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marek Kašík 2012-10-25 07:01:26 EDT
You are right, vinagre doesn't offer changing of resolution of the host (except of running in fullscreen mode).

You can use "rdesktop {-u username} -K -g 1024x768" instead for now.

Marek
Comment 3 Marek Kašík 2013-05-09 06:23:36 EDT
I've created a patch adding spin buttons for specification of the size of the screen. It is attached in the upstream bug.
I'm moving this to 7.1 because this feature request needs an UI change.
Comment 4 Marek Kašík 2013-05-14 12:01:38 EDT
The patch has been committed upstream (vinagre-3.9.x).
Comment 15 Vaclav Ehrlich 2014-11-18 09:28:06 EST
Because bug's title coresponds to VNC  and bg's description to RDP I've tested both....both cases are working with vinagre-3.8.2-12.
Comment 17 errata-xmlrpc 2015-03-05 05:24:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0448.html

Note You need to log in before you can comment on or make changes to this bug.