Bug 862407 - [ Deploy the CarMart Quickstart ] Deployment Failed
[ Deploy the CarMart Quickstart ] Deployment Failed
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 15:40 EDT by Frederic Hornain
Modified: 2012-10-03 04:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.6 Build Filter: null Build Name: Build Date: 18-09-2012 16:08:02
Last Closed: 2012-10-03 04:36:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EAP's configuration (14.81 KB, text/xml)
2012-10-03 03:07 EDT, Martin Gencur
no flags Details

  None (edit)
Description Frederic Hornain 2012-10-02 15:40:04 EDT
Description of problem:

In the "9.4 .2. Deploy the CarMart Quickstart to the JBoss Application Server"
Chapter of "Getting Started Guide An introductory guide for JBoss Data Grid 6.
Edition 1", I tried to run the following command however I had that following error :


mvn jboss-as:deploy -Plibrary-jbossas 
/usr/lib/jvm/java
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building CarMart Single Node (No Cluster) 1.0.1-redhat-1
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] --- jboss-as-maven-plugin:7.1.0.CR1b:deploy (default-cli) @ carmart-quickstart ---
[INFO] Executing goal deploy on server localhost (127.0.0.1) port 9999.
Oct 02, 2012 9:34:51 PM org.xnio.Xnio <clinit>
INFO: XNIO Version 3.0.0.CR7
Oct 02, 2012 9:34:51 PM org.xnio.nio.NioXnio <clinit>
INFO: XNIO NIO Implementation Version 3.0.0.CR7
Oct 02, 2012 9:34:51 PM org.jboss.remoting3.EndpointImpl <clinit>
INFO: JBoss Remoting version 3.2.0.CR8
Authenticating against security realm: ManagementRealm
Username:admin
Password:
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 19.972s
[INFO] Finished at: Tue Oct 02 21:35:09 CEST 2012
[INFO] Final Memory: 14M/166M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.jboss.as.plugins:jboss-as-maven-plugin:7.1.0.CR1b:deploy (default-cli) on project carmart-quickstart: Could not execute goal deploy on carmart-quickstart.war. Reason: Deployment failed and was rolled back. -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

BR
/f
Comment 1 Misha H. Ali 2012-10-02 17:45:37 EDT
Thanks for reporting this, Frederic.

Martin, adding a NEEDINFO for you to help determine what has gone wrong as you are the creator for this quickstart.
Comment 2 Misha H. Ali 2012-10-02 17:47:36 EDT
Sorry, saw the subsequent bug [1] after this. Is this problem also resolved when you corrected the Maven directory path, Frederic? Please confirm whether the problem persists or close if this is also resolved by the fix at your end.

[1] - https://bugzilla.redhat.com/show_bug.cgi?id=862342
Comment 3 Frederic Hornain 2012-10-03 02:11:45 EDT
Hi Misha,

The Problem persists even with the correct Maven Path.
Here is the output from EAP side :

08:10:21,128 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "carmart-quickstart.war"
08:10:21,725 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC000001: Failed to start service jboss.module.service."deployment.carmart-quickstart.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.carmart-quickstart.war".main: JBAS018759: Failed to load module: deployment.carmart-quickstart.war:main
	at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:92) [jboss-as-server-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_06-icedtea]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_06-icedtea]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_06-icedtea]
Caused by: org.jboss.modules.ModuleNotFoundException: Module org.jboss.logging.jul-to-slf4j-stub:main is not found in local module loader @7977cdb1 (roots: /home/fhornain/Downloads/MyJava/jboss-datagrid-server-6.0.1.GA/modules)
	at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126)
	at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275)
	at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222)
	at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94)
	at org.jboss.modules.Module.addPaths(Module.java:851)
	at org.jboss.modules.Module.link(Module.java:1206)
	at org.jboss.modules.Module.relinkIfNecessary(Module.java:1235)
	at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208)
	at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	... 5 more

08:10:21,933 INFO  [org.jboss.as.server] (management-handler-thread - 4) JBAS015870: Deploy of deployment "carmart-quickstart.war" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.module.service.\"deployment.carmart-quickstart.war\".main" => "org.jboss.msc.service.StartException in service jboss.module.service.\"deployment.carmart-quickstart.war\".main: JBAS018759: Failed to load module: deployment.carmart-quickstart.war:main
    Caused by: org.jboss.modules.ModuleNotFoundException: Module org.jboss.logging.jul-to-slf4j-stub:main is not found in local module loader @7977cdb1 (roots: /home/fhornain/Downloads/MyJava/jboss-datagrid-server-6.0.1.GA/modules)"},"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.deployment.unit.\"carmart-quickstart.war\".POST_MODULE Missing[JBAS014861: <one or more transitive dependencies>]"]}
08:10:21,947 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment carmart-quickstart.war in 15ms

Thanks for your help on this.

BR
Frederic
Comment 4 Martin Gencur 2012-10-03 03:07:27 EDT
Created attachment 620646 [details]
EAP's configuration
Comment 5 Martin Gencur 2012-10-03 03:10:35 EDT
Hello Frederic,
I was not able to reproduce your problem. I tried to build the application with fresh maven repository (I simply put this into my ~/.m2/settings.xml: <localRepository>/home/mgencur/infinispan/6.0.1/ga/jboss-datagrid-maven-repository-6.0.1.GA</localRepository>, right after unzipping the maven repo). The deployment was, too, successfull for me, both into JBoss AS 7.1.1.Final and EAP 6.0.0.GA. The EAP and JBossAS distributions were fresh, unmodified, used right after unzipping the zip files. 

It seems to me that your standalone.xml file in EAP is probably modified in some way (specific security settings enabled). My EAP distribution also contains the org.jboss.logging.jul-to-slf4j-stub module so I was not able to reproduce your second problem either. Attaching my standalone.xml file so that we are on the same page.
Comment 6 Martin Gencur 2012-10-03 03:19:04 EDT
Ah, I know where the problem is. You used JDG and tried to deploy to it even though you are saying you used EAP, is that right? The log says it: /home/fhornain/Downloads/MyJava/jboss-datagrid-server-6.0.1.GA/modules 

JDG (JBoss Data Grid) does not support deployment of applications. The quickstart applications must be deployed to EAP or JBoss AS which support deployment of applications, as proposed in the Getting Started Guide.
Comment 7 Frederic Hornain 2012-10-03 03:48:13 EDT
Martin,

I think you found it. I will do the test on my side with EAP and JDG and I will keep you in touch.

Thanks again for this.
Comment 8 Martin Gencur 2012-10-03 03:53:27 EDT
Just a note: For "libary" mode you need just one EAP instance running, no JDG. On the other hand, in "client-server" mode you need both EAP and JDG running.
Comment 9 Frederic Hornain 2012-10-03 04:36:17 EDT
Martin,

FIXED.

Thanks for your help Martin.

BR
/f

Note You need to log in before you can comment on or make changes to this bug.