Bug 862427 - ehci_hcd dies after plugging webcam
ehci_hcd dies after plugging webcam
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 16:53 EDT by Maxim Iorsh
Modified: 2013-06-03 16:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 16:40:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Iorsh 2012-10-02 16:53:02 EDT
Description of problem: USB devices conflict. When a USB device plugged in, some previously connected USB device stops functioning (usually WiFi adapter)

Version-Release number of selected component (if applicable):


How reproducible: Plug in USB camera. Observe network disconnected


Steps to Reproduce:
1.
[iorsh@localhost ~]$ lsusb
Bus 001 Device 003: ID 148f:2573 Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter
Bus 001 Device 004: ID 03f0:4717 Hewlett-Packard Color LaserJet CP1215
Bus 001 Device 006: ID 18e3:7102 Fitipower Integrated Technology Inc Multi Card Reader (Internal)
Bus 002 Device 002: ID 04f2:0618 Chicony Electronics Co., Ltd 
Bus 004 Device 002: ID 24ae:2000  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

2. Plug in web camera

3.
[iorsh@localhost ~]$ lsusb
Bus 001 Device 007: ID 0ac8:c40a Z-Star Microelectronics Corp. 
Bus 001 Device 004: ID 03f0:4717 Hewlett-Packard Color LaserJet CP1215
Bus 001 Device 006: ID 18e3:7102 Fitipower Integrated Technology Inc Multi Card Reader (Internal)
Bus 002 Device 002: ID 04f2:0618 Chicony Electronics Co., Ltd 
Bus 004 Device 002: ID 24ae:2000  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Actual results:
Observe "Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter" now missing in the list

Expected results:
"Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter" present in the list

Additional info:
Sometimes all these devices (card reader, keyboard, mouse, printer, wifi, webcam) somehow manage to coexist, but then plugging in an iphone or a still camera causes one of them to die. WiFi or printer is usually the first, and then USB hot plugging breaks completely. For example, if I pull and replug the mouse, it won't be recognized.
Comment 1 Maxim Iorsh 2012-10-10 17:05:05 EDT
Added

echo -n "0000:00:13.5" > /sys/bus/pci/drivers/ehci_hcd/unbind

to /etc/rc.d/rc.local . Now everything works.
Comment 2 Josh Boyer 2013-03-12 15:46:11 EDT
Are you still seeing this with 3.7.9 or 3.8.2 in updates-testing?
Comment 3 Maxim Iorsh 2013-03-12 18:37:32 EDT
On 3.7.9-104 in updates, no crashes anymore, but the webcam just doesn't work. All other USB 2.0 perpherals do fine and fast.

Reverting back to uhci-hcd, webcam works fine.

Do you want me to check explicitly updates-testing repository?
Comment 4 Josh Boyer 2013-06-03 15:12:50 EDT
Not sure why it would only work when using uhci unless there is some bug in the hardware itself.

Are you still seeing this with the 3.9.4 kernel in updates-testing?
Comment 5 Maxim Iorsh 2013-06-03 16:20:31 EDT
Looks like the problem disappeared in kernel 3.8.13, camera works fine with hi-speed usb driver
Comment 6 Josh Boyer 2013-06-03 16:40:21 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.