Bug 862440 - [TEXT] improve candoaction message preventing moving an spm node to maintenance.
[TEXT] improve candoaction message preventing moving an spm node to maintenance.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Vered Volansky
vvyazmin@redhat.com
storage
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 18:28 EDT by Itamar Heim
Modified: 2016-02-10 15:22 EST (History)
10 users (show)

See Also:
Fixed In Version: SF6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Itamar Heim 2012-10-02 18:28:12 EDT
in http://post-office.corp.redhat.com/archives/rhev-tech/2012-September/msg00445.html
"We have a single host on rhev 3 which is marked as spm.  This host is presently in non responsive state. When we try to put it on maintenance, we receive this error :
Error: Cannot switch Host to Maintenance mode, Host is Storage Pool Manager and it is non-responsive.

Is there a way to fix that ?  We've installed a bunch of vm and we don't want to loose them. "

since this question comes up a lot, we should consider improving the error message to explain:
1. if power management is configured, engine will fence automatically.
2. if power management is not configured, either bring the node back up, or verify the node is really down, right click the host and confirm the node was shutdown manually, to release the SPM resource.
Comment 1 Vered Volansky 2013-01-03 02:41:06 EST
Fixed, Message is now:
Error while executing action: Cannot switch Host to Maintenance mode.
Host is Storage Pool Manager and is in Non-Responsive state.
- If power management is configured, engine will fence automatically.
- Otherwise, either bring the node back up, or release the SPM resource.
To do so, verify the node is really down, right click the host and confirm the node was shutdown manually.

http://gerrit.ovirt.org/#/c/10599/
Change-Id: Ic5e0e3f85d2f1ff1a94b152d6d739308fb970113
Comment 2 Allon Mureinik 2013-01-14 03:32:47 EST
merged Ic5e0e3f85d2f1ff1a94b152d6d739308fb970113 u/s.
Comment 3 vvyazmin@redhat.com 2013-02-07 04:31:07 EST
No issues are found

Verified on RHEVM 3.2 - SF06 environment:

RHEVM: rhevm-3.2.0-7.el6ev.noarch
VDSM: vdsm-4.10.2-7.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-18.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 4 Itamar Heim 2013-06-11 05:00:54 EDT
3.2 has been released
Comment 5 Itamar Heim 2013-06-11 05:00:56 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 05:00:57 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 05:02:12 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 05:31:31 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.