Bug 86275 - system status doesn't update, package list update fails
system status doesn't update, package list update fails
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-18 12:54 EST by bill parducci
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 15:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bill parducci 2003-03-18 12:54:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
rhn says that one of my systems (oink) says has outstanding errata:

Status  Errata  Packages  System  Base Channel  Entitlement
System Fully Updated 0 0 foo Red Hat Linux 8.0 Basic
System Fully Updated 0 0 bar Red Hat Linux 7.3 Basic
System Fully Updated 0 0 blah Red Hat Linux 8.0 Basic
Critical Update Available 4 2 oink Red Hat Linux 8.0 Basic

but will not update this information. oddly, i can add new packages and that
works fine.

Version-Release number of selected component (if applicable):
rhnlib-1.0-1; rhn-applet-2.0.0-28; up2date-3.0.7-1

How reproducible:
Always

Steps to Reproduce:

i schedule the packages to be updated (in this example kernel-2.4.18-27.8.0) and
run rhn_check (or up2date i have performed both manually a number of times).
note: kernel is NOT skipped in /etc/sysconfig/up2date

rhn shows that the job completed 'sucessfullly' for all packages scheduled:

This action's status is: Completed.
The client picked up this action on 2003-03-18 12:35:12 (EST).
The client completed this action on 2003-03-18 12:35:19 (EST).
Client execution returned "Packages were installed successfully" (code 0)
Errata Affected:

    * RHBA-2003:069-12 (Updated 2.4 kernel fixes tg3 driver hang)

Time: 2003-03-18 12:32:47 (EST)

running rhn_check tells me that the package is already installed. this is
confirmed locally on the machine:

# rpm -qa |grep kern
kernel-2.4.18-27.8.0

but rhn continues to show the *same* packages as needing to be updated.

i tried to perform a package list refresh, but that flat out fails:

This action's status is: Failed.
The client picked up this action on 2003-03-18 00:49:40 (EST).
The client completed this action on 2003-03-18 00:49:43 (EST).
Client execution returned "Error refreshing package list" (code 20)
Time: 2003-03-18 00:49:19 (EST)

not sure what to try now. rpm seems to be ok so i don't think that it is an rpm
db issue.
Comment 1 bill parducci 2003-03-28 00:14:09 EST
i have played with this more and noticed that the problem seems to stem from
having packages that were deleted by hand. once this is done, you cannot go back
to rhn and tell it to 'delete' these packages ('update package list' fails as
mentioned above). the job to 'delete' the packages shows up and is pulled down
to the machine, but nothing happens. of course, this is expeetcd on the client
since the packages were already removed, but rhn central still shows them as
installed. interesting to note is that the job is marked as COMPLETE (not failed).
Comment 2 Josef Komenda 2003-03-28 09:11:08 EST
You said the rpd db seems ok, did you run rpm --rebuilddb ? Also, try running
up2date -p and see what happens. 
Comment 3 bill parducci 2003-03-28 11:52:49 EST
# up2date -p -v
Updating package profile...

# rhn_check

rhn: out of date

rhn # package list refresh

# rhn_ch
ERROR: refreshing remote package list for System Profileeck

rhn:
This action's status is: Failed.
The client picked up this action on 2003-03-28 11:36:10 (EST).
The client completed this action on 2003-03-28 11:36:12 (EST).
Client execution returned "Error refreshing package list" (code 20)

# rpm --rebuilddb

# up2date -p -v
Updating package profile...

rhn: out of date

rhn # package list refresh

# rhn_check
ERROR: refreshing remote package list for System Profile

Note You need to log in before you can comment on or make changes to this bug.