Bug 862827 - RPM - installation guide - full sync with dev/productization
RPM - installation guide - full sync with dev/productization
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-Installation-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 12:18 EDT by Ondrej Chaloupka
Modified: 2012-11-08 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2012-10-03 12:18:52 EDT
Please, check information how the RPM should be installed with productization and sync the info with current documentation.

The info in previous document proposed by Wei Nan Li - https://docspace.corp.redhat.com/docs/DOC-108784 - does not fit with the current state of documentation in general.

- what are supported cases for intallation? Just com groups or list of packages as well?
- what packages should be really installed (as example: the document does not mention package hibernate4, documentation does and the package is build from brew. It could be maybe installed as dependency. But should it be in list of packages or not...?)
- check of other issues - e.g. should be customer informed about devel packages? (https://bugzilla.redhat.com/show_bug.cgi?id=860272)


These points are just example what seems to me not being correct. But it's needed to sync the ideas of dev/productization how really whole installation process of RPM should be done with the documentation.
Comment 1 Ondrej Chaloupka 2012-10-03 12:20:12 EDT
Related to: https://bugzilla.redhat.com/show_bug.cgi?id=861924
Comment 2 Ondrej Chaloupka 2012-10-03 12:25:51 EDT
Other point:
- is it needed to set exactarch to 0 during the installation?
Comment 4 Ondrej Chaloupka 2012-10-08 03:18:30 EDT
Hi, thank you Misha for comments.
- just I'm once again adding point whether it's necessary to set exactarch to 0 during the installation?

Then I'm sorry but I'm really not sure about the documentation as a whole. It was a copy of EWS1 but the EWS2 should be installed slightly in other way.
Wouldn't be better to make an introduction about ways of installation on first page of RPM? Like you can install it by groups or package by package?
Then inform the customer which packages are part of which group and then say how the command for installation package by package should look like?

I would suppose like a bigger rework of the guide. Not sure whether it's possible or how normal process is?



Then the list on the first RPM page:
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-Installing_EWS_from_RPM_Packages.html

is probably depracated and not in sync (currently after the changes from other bugzillas) with command 2.15/2A

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-Subscribing_to_RHN_Channels_and_Installing_EWS_from_RPM_Files-Linux.html
Comment 7 Ondrej Chaloupka 2012-10-09 04:55:04 EDT
Hi,

thank you for clarification.

I'm sorry Misha, I didn't write my question in understandable way. It was just a remark about installation guide structure. But the main point was that you have pointed out. Will the customer understand that he has two ways of installation that are equal?

But I'm putting this BZ once more back to assigned and the reason is that the group jboss-ews2plus is not in sync. Or I think so. Please, correct me in my guess.

The Wei Nan defines that the package contains packages
hibernate4-envers hibernate4-core hibernate4-entitymanager hibernate4-c3p0
but on this jira the xml talks about others
<packagereq type="mandatory">hibernate-jpa-2.0-api</packagereq>
<packagereq type="mandatory">hibernate3-commons-annotations</packagereq>
<packagereq type="mandatory">hibernate4</packagereq>
<packagereq type="mandatory">hibernate4-core</packagereq>
<packagereq type="mandatory">hibernate4-envers</packagereq>
<packagereq type="mandatory">hibernate4-entitymanager</packagereq>
<packagereq type="mandatory">hibernate4-c3p0</packagereq>


Then I put my question about exactarch to 0 during the installation to comment
https://docspace.corp.redhat.com/docs/DOC-108784#comment-44911
Can you, please, Wai Nan give me a feedback about this?
Comment 8 Ondrej Chaloupka 2012-10-09 10:15:35 EDT
I've checked the groups from rhn_qa channel and the yum tells me that:

jboss-ews2 contains:
httpd
mod_auth_kerb
mod_cluster
mod_cluster-native
mod_cluster-tomcat6
mod_cluster-tomcat7
mod_jk
mod_rt
mod_snmp
tomcat-native
tomcat6
tomcat6-admin-webapps
tomcat6-webapps
tomcat7
tomcat7-admin-webapps
tomcat7-webapps

which means that the list of packages in install guide should be enhanced for
mod_cluster-tomcat6 and mod_cluster-tomcat7
and these packages should be removed from optional section
And mod_nss should be removed from main list of packages and moved to optional ones.

jboss-ews2plus contains:
antlr-eap6
dom4j-eap6
hibernate-jpa-2.0-api
hibernate3-commons-annotations
hibernate4
javassist-eap6
jboss-logging
jboss-transaction-api_1.1_spec

which  means that following packages should be then removed from optional packages:
hibernate-jpa-2.0-api-javadoc
and packages:
hibernate4-envers hibernate4-core hibernate4-entitymanager hibernate4-c3p0
are not mentioned in list of packages from group.

Wei Nan, please, clarify what is correct set of packages to install. 
I would really need to know what to test for package by package installation and what is correct list of extra packages for EWS2.

Thank you
Comment 9 Misha H. Ali 2012-10-09 18:17:43 EDT
From Chris's email, it looks like the packages should be the following:

   <group>
     <id>jboss-ews2</id>
     <uservisible>true</uservisible>
     <default>false</default>
     <_name>JBoss Enterprise Web Server 2</_name>
     <packagelist>
       <packagereq type="mandatory">httpd</packagereq>
       <packagereq type="mandatory">mod_auth_kerb</packagereq>
       <packagereq type="mandatory">mod_cluster</packagereq>
       <packagereq type="mandatory">mod_cluster-native</packagereq>
       <packagereq type="mandatory">mod_jk</packagereq>
       <packagereq type="mandatory">mod_rt</packagereq>
       <packagereq type="mandatory">mod_snmp</packagereq>
       <packagereq type="mandatory">mod_cluster-tomcat6</packagereq>
       <packagereq type="mandatory">mod_cluster-tomcat7</packagereq>
       <packagereq type="mandatory">tomcat6</packagereq>
       <packagereq type="mandatory">tomcat6-admin-webapps</packagereq>
       <packagereq type="mandatory">tomcat6-webapps</packagereq>
       <packagereq type="mandatory">tomcat7</packagereq>
       <packagereq type="mandatory">tomcat7-admin-webapps</packagereq>
       <packagereq type="mandatory">tomcat7-webapps</packagereq>
       <packagereq type="mandatory">tomcat-native</packagereq>
     </packagelist>
   </group>

   <group>
     <id>jboss-ews2plus</id>
     <uservisible>true</uservisible>
     <default>false</default>
     <_name>JBoss Enterprise Web Server 2 Plus</_name>
     <packagelist>
       <packagereq type="mandatory">hibernate4-core</packagereq>
       <packagereq type="mandatory">hibernate4-envers</packagereq>
       <packagereq type="mandatory">hibernate4-entitymanager</packagereq>
       <packagereq type="mandatory">hibernate4-c3p0</packagereq>
     </packagelist>
   </group>

I'll update these and confirm once the changes are done.
Comment 10 Misha H. Ali 2012-10-09 18:53:22 EDT
The package names are now reconciled with the list above.

Additionally, I have added a section to address Ondrej's feedback about being explicit about the two methods of RPM installation.
Comment 12 Ondrej Chaloupka 2012-10-10 02:43:07 EDT
Hi,

thank you it seems fine. 
Sorry but I have one more remark.
Package mod_auth_kerb should be added to list of standard packages and removed from optional one.
Comment 13 Misha H. Ali 2012-10-10 02:48:59 EDT
Hi Ondrej,

No problem, but did you mean that mod_auth_kerb should be in the optional packages and taken out of the standard ones? I ask because the only instance I can spot where it is listed in the expanded packages is in the standard install, here:

Procedure 2.15. Installing Enterprise Web Server from RPM Packages

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-Subscribing_to_RHN_Channels_and_Installing_EWS_from_RPM_Files-Linux.html

Could you clarify which one you meant?
Comment 14 Ondrej Chaloupka 2012-10-10 02:55:24 EDT
Ah, ok, my mistake.

It was just about this section:
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-RPM_Packages.html

I think that the mod_auth_kerb package should be there because that section talks about basic packages that are involved in ews2 installation.
Comment 15 Misha H. Ali 2012-10-17 00:12:50 EDT
No problem, mod_auth_kerb is now added.
Comment 17 Ondrej Chaloupka 2012-10-22 04:03:52 EDT
I suppose that this problem is solved now.
Comment 18 Misha H. Ali 2012-11-08 17:11:22 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.