Bug 862840 - [US2105][fork] Failed to delete an app
[US2105][fork] Failed to delete an app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks: 862855
  Show dependency treegraph
 
Reported: 2012-10-03 14:05 EDT by Chandrika Gole
Modified: 2015-05-14 22:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 862855 (view as bug list)
Environment:
Last Closed: 2012-11-06 13:49:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrika Gole 2012-10-03 14:05:52 EDT
Description of problem:
failed to delete app on fork ami fork_ami_US2105_203 (ami-3943fe50)

Version-Release number of selected component (if applicable):
fork_ami_US2105_203 (ami-3943fe50)

How reproducible:
sometimes

Steps to Reproduce:
1. Create an app
2. Delete it
3.
  
Actual results:
[root@ip-10-118-74-211 ~]# rhc-ctl-app -a php -c destroy
Password: 

!!!! WARNING !!!! WARNING !!!! WARNING !!!!
You are about to destroy the php application.

This is NOT reversible, all remote data for this application will be removed.
Do you want to destroy this application (y/n): y
/usr/lib/ruby/1.8/timeout.rb:64:in `rbuf_fill': execution expired (Timeout::Error)
	from /usr/lib/ruby/1.8/net/protocol.rb:134:in `rbuf_fill'
	from /usr/lib/ruby/1.8/net/protocol.rb:116:in `readuntil'
	from /usr/lib/ruby/1.8/net/protocol.rb:126:in `readline'
	from /usr/lib/ruby/1.8/net/http.rb:2028:in `read_status_line'
	from /usr/lib/ruby/1.8/net/http.rb:2017:in `read_new'
	from /usr/lib/ruby/1.8/net/http.rb:1051:in `__request__'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/net_http_ext.rb:17:in `request'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc-common.rb:376:in `http_post'
	from /usr/lib/ruby/1.8/net/http.rb:543:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc-common.rb:376:in `http_post'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/lib/rhc-common.rb:818:in `ctl_app'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.99.3/bin/rhc-ctl-app:171
	from /usr/bin/rhc-ctl-app:19:in `load'
	from /usr/bin/rhc-ctl-app:19



Expected results:

App should be deleted
Additional info:

Trying to reproduce it
Comment 1 Mrunal Patel 2012-10-03 15:58:49 EDT
Can't reproduce.
Comment 2 Chandrika Gole 2012-10-03 16:20:55 EDT
Lowering priority and severity
Comment 3 Chandrika Gole 2012-10-03 17:29:31 EDT
cannot reproduce

Note You need to log in before you can comment on or make changes to this bug.