Bug 862899 - [RFE] Extend the qpidd --wait option to work at shutdown
[RFE] Extend the qpidd --wait option to work at shutdown
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
2.2
Unspecified Unspecified
medium Severity medium
: 3.0
: ---
Assigned To: Ernie
Leonid Zhaldybin
: EasyFix, FutureFeature, Patch, Triaged
Depends On:
Blocks: 785156
  Show dependency treegraph
 
Reported: 2012-10-03 16:34 EDT by Stuart Auchterlonie
Modified: 2014-09-24 11:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-4.el6, qpid-cpp-0.22-4.el5
Doc Type: Enhancement
Doc Text:
It is now possible to use the --wait option available in C++ Brokers to control both startup and shutdown wait times. Brokers with large databases and process spaces may take longer than the hard-coded 10 seconds to shut down successfully. Enabling the --wait option to use it's value in the shutdown timer allows users to specify the shutdown wait time beyond 10 seconds. This allows users to successfully shut down large-scale brokers without error.
Story Points: ---
Clone Of:
: 957961 (view as bug list)
Environment:
Last Closed: 2014-09-24 11:04:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trivial patch (2.78 KB, patch)
2012-10-18 04:57 EDT, Pavel Moravec
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4758 None None None Never
Red Hat Knowledge Base (Solution) 238093 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 15:00:06 EDT

  None (edit)
Comment 2 Pavel Moravec 2012-10-18 04:57:43 EDT
Created attachment 629242 [details]
trivial patch

Trivial patch for qpid 0.18: instead of waiting 10 seconds during shutdown, --wait option is taken into account.

One further documentation fix for the same is included.
Comment 5 Justin Ross 2012-11-06 15:00:29 EST
Approving this for 2.4, but keep in mind that the command line interface may change.
Comment 6 Ernie 2013-03-20 14:32:04 EDT
Compiles and works on trunk. Note: the patch is reversed so use the -R option on the patch command line to apply.
Comment 7 Chuck Rolke 2013-04-24 10:49:01 EDT
Fixed upstream at Committed revision 1471442.
Comment 11 Leonid Zhaldybin 2013-07-25 09:46:22 EDT
Tested on RHEL6.4 (both i386 x86_64). This feature was implemented and works as expected. When the qpidd is started with the options "-q --wait N", it waits for N seconds for the running qpidd broker to shut down.

Packages used for testing:

python-qpid-0.22-4.el6
python-qpid-qmf-0.22-6.el6
qpid-cpp-client-0.22-7.el6
qpid-cpp-client-devel-0.22-7.el6
qpid-cpp-client-devel-docs-0.22-7.el6
qpid-cpp-client-rdma-0.22-7.el6
qpid-cpp-client-ssl-0.22-7.el6
qpid-cpp-server-0.22-7.el6
qpid-cpp-server-devel-0.22-7.el6
qpid-cpp-server-ha-0.22-7.el6
qpid-cpp-server-rdma-0.22-7.el6
qpid-cpp-server-ssl-0.22-7.el6
qpid-cpp-server-store-0.22-7.el6
qpid-cpp-server-xml-0.22-7.el6
qpid-java-client-0.22-4.el6
qpid-java-common-0.22-4.el6
qpid-java-example-0.22-4.el6
qpid-proton-c-0.4-2.2.el6
qpid-qmf-0.22-6.el6
qpid-qmf-devel-0.22-6.el6
qpid-tools-0.22-3.el6

-> VERIFIED
Comment 12 errata-xmlrpc 2014-09-24 11:04:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.