Bug 862927 - Error while compiling assets
Error while compiling assets
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
: 862994 862998 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 18:44 EDT by Thomas Wiest
Modified: 2015-05-14 21:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:50:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Wiest 2012-10-03 18:44:05 EDT
Description of problem:
Javascript on the web site in INT isn't working and I'm seeing errors like this in the site's production.log file:

2012-10-03 18:29:41.718 [ERROR] Error compiling asset console.js: (pid:19114)
2012-10-03 18:29:41.718 [ERROR] Sprockets::FileNotFound: couldn't find file 'jquery'
  (in /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-console-0.0.4/app/assets/javascripts/console.js:1) (pid:19114)

Version-Release number of selected component (if applicable):
rhc-site-static-0.99.6-4.el6_3.noarch
rhc-site-0.99.6-4.el6_3.noarch

How reproducible:
Very

Steps to Reproduce:
1. tail the site production.log file
2. Login to the site
3. Notice the errors like above
  
Actual results:
Errors and javascript in site is broken

Expected results:
No errors and javascript should work
Comment 1 Clayton Coleman 2012-10-04 17:39:21 EDT
https://github.com/openshift/li/pull/451

Not yet on INT, blocked right now by crankcase builds.
Comment 2 Clayton Coleman 2012-10-04 17:40:03 EDT
*** Bug 862994 has been marked as a duplicate of this bug. ***
Comment 3 Clayton Coleman 2012-10-04 17:40:45 EDT
*** Bug 862998 has been marked as a duplicate of this bug. ***
Comment 4 Peter Ruan 2012-10-05 18:13:16 EDT
Javascript code now works in INT>

Note You need to log in before you can comment on or make changes to this bug.