Bug 862933 - corrupt rpm files during
corrupt rpm files during
Status: CLOSED DUPLICATE of bug 864775
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 20:10 EDT by Peter Ruan
Modified: 2015-05-14 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 16:06:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2012-10-03 20:10:07 EDT
Description of problem:

Updating   : mod-php-5.3-apache2-zend-server-5.3.14-7.x86_64                         1/315 
Error unpacking rpm package mod-php-5.3-apache2-zend-server-5.3.14-7.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/php.ini;506cd21f: cpio: open
Error unpacking rpm package php-5.3-ldap-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/ldap.ini;506cd21f: cpio: mkdir
Error unpacking rpm package php-5.3-imap-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/imap.ini;506cd21f: cpio: mkdir
Error unpacking rpm package php-5.3-fcgi-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/gui/lighttpd/etc/php-fcgi.ini;506cd21f: cpio: open
Error unpacking rpm package php-5.3-pdo-mysql-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/pdo_mysql.ini;506cd21f: cpio: mkdir
Error unpacking rpm package php-5.3-pdo-pgsql-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/pdo_pgsql.ini;506cd21f: cpio: mkdir
Error unpacking rpm package zend-server-framework2-2.0.2-291.noarch
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/zf2.ini;506cd21f: cpio: mkdir

Error unpacking rpm package php-5.3-zip-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/zip.ini;506cd21f: cpio: mkdir
  Updating   : php-5.3-gui-zend-server-6.1.38-65.noarch   


...

Zend Server stopped.
chgrp: invalid group: `zend'
chmod: cannot access `/usr/local/zend/etc/*.ini': No such file or directory
chmod: cannot access `/usr/local/zend/etc/*.xml': No such file or directory
chmod: cannot access `/usr/local/zend/etc/conf.d/*.ini': No such file or directory
chmod: cannot access `/usr/local/zend/etc/conf.d': No such file or directory
chown: invalid group: `48:zend'

...
Warning: parse_ini_file(/usr/local/zend/etc/monitor_node.ini): failed to open stream: No such file or directory in /usr/local/zend/share/scripts/zs_create_databases.php on line 525
ERROR: Cannot parse monitor ini file /usr/local/zend/etc/monitor_node.ini

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000] [14] unable to open database file' in /usr/local/zend/share/scripts/zs_jq_db_handler.php:15
Stack trace:
#0 /usr/local/zend/share/scripts/zs_jq_db_handler.php(15): PDO->__construct('sqlite:/db/jobq...')
#1 /usr/local/zend/share/scripts/zs_create_databases.php(680): JQDBHandler->__construct()
#2 {main}
  thrown in /usr/local/zend/share/scripts/zs_jq_db_handler.php on line 15
X-Powered-By: PHP/5.3.14 ZendServer/5.0
Content-type: text/html


Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000] [14] unable to open database file' in /usr/local/zend/share/scripts/zs_jq_db_handler.php:15
Stack trace:
#0 /usr/local/zend/share/scripts/zs_jq_db_handler.php(15): PDO->__construct('sqlite:/db/jobq...')
#1 /usr/local/zend/share/scripts/zs_create_databases.php(666): JQDBHandler->__construct()
#2 {main}
  thrown in /usr/local/zend/share/scripts/zs_jq_db_handler.php on line 15
chown: invalid user: `zend:apache'
chown: invalid group: `apache:zend'





Version-Release number of selected component (if applicable):


How reproducible:
follow directions on migration as given in
https://engineering.redhat.com/trac/Libra/wiki/Test_Migrations_Fork_Ami

Steps to Reproduce:
1. yum -y install yum-priorities
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rob Millner 2012-10-04 13:06:46 EDT
It seems as though the problem is the Zend cartridge.  Passing to Lili but this may be an operations issue.
Comment 2 Mike McGrath 2012-10-10 14:27:43 EDT
We've deployed this to prod already without issue so we think whatever went wrong was fixed, if that's incorrect please re-open.
Comment 3 Peter Ruan 2012-10-10 18:54:04 EDT
Still seeing the same issue with a stg_ami_239 instance 

Error unpacking rpm package mod-php-5.3-apache2-zend-server-5.3.14-7.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/php.ini;5075fb1d: cpio: open
                                                                    6/316 
Error unpacking rpm package php-5.3-ldap-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/ldap.ini;5075fb1d: cpio: mkdir
  
Error unpacking rpm package php-5.3-imap-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/imap.ini;5075fb1d: cpio: mkdir
  Updating   : php-5.3-fcgi-zend-server-5.3.14-3.x86_64                                                                                                                10/316 
Error unpacking rpm package php-5.3-fcgi-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/gui/lighttpd/etc/php-fcgi.ini;5075fb1d: cpio: open
  Updating   : ruby193-rubygem-bigdecimal-
  Updating   : php-5.3-pdo-pgsql-zend-server-5.3.14-3.x86_64                                                                                                           28/316 
Error unpacking rpm package php-5.3-pdo-pgsql-zend-server-5.3.14-3.x86_64
error: unpacking of archive failed on file /usr/local/zend/etc/conf.d/pdo_pgsql.ini;5075fb1d: cpio: mkdir


Warning: parse_ini_file(/usr/local/zend/etc/monitor_node.ini): failed to open stream: No such file or directory in /usr/local/zend/share/scripts/zs_create_databases.php on line 525
ERROR: Cannot parse monitor ini file /usr/local/zend/etc/monitor_node.ini

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000] [14] unable to open database file' in /usr/local/zend/share/scripts/zs_jq_db_handler.php:15
Stack trace:
#0 /usr/local/zend/share/scripts/zs_jq_db_handler.php(15): PDO->__construct('sqlite:/db/jobq...')
#1 /usr/local/zend/share/scripts/zs_create_databases.php(680): JQDBHandler->__construct()
#2 {main}
  thrown in /usr/local/zend/share/scripts/zs_jq_db_handler.php on line 15
X-Powered-By: PHP/5.3.14 ZendServer/5.0
Content-type: text/html


Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000] [14] unable to open database file' in /usr/local/zend/share/scripts/zs_jq_db_handler.php:15
Stack trace:
#0 /usr/local/zend/share/scripts/zs_jq_db_handler.php(15): PDO->__construct('sqlite:/db/jobq...')
#1 /usr/local/zend/share/scripts/zs_create_databases.php(666): JQDBHandler->__construct()
#2 {main}
  thrown in /usr/local/zend/share/scripts/zs_jq_db_handler.php on line 15
chown: invalid user: `zend:apache'
chown: invalid group: `apache:zend'
#############################################################################
For information about ZendServer, please refer to /usr/local/zend/doc/README.
#############################################################################
Comment 4 Lili Nader 2012-10-15 16:06:12 EDT

*** This bug has been marked as a duplicate of bug 864775 ***

Note You need to log in before you can comment on or make changes to this bug.