Bug 862938 - [RFE]: Support the OpenSSL-style cipher designation in a 'mod_nss' configuration file
[RFE]: Support the OpenSSL-style cipher designation in a 'mod_nss' configurat...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mod_nss (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Harmsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-03 21:10 EDT by Matthew Harmsen
Modified: 2015-10-02 17:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.0.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 17:35:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Harmsen 2012-10-03 21:10:42 EDT
Per the comment from rcritten@redhat.com on 2012-01-11 09:20:09 EST in  "Bugzilla Bug #797345 - mod_nss insists on Required value NSSCipherSuite not set.": 

All ciphers are disabled by default, I wanted users to have to enable only those ciphers they need. I've always intended on supporting the OpenSSL-style cipher configuration line which can be simpler at times, I just haven't had a chance to port over similar code from nss_compat_ossl.

NOTE:  See 'nss_compat_ossl/src/ssl.c:nss_parse_ciphers()'.
Comment 1 Rob Crittenden 2015-10-02 17:35:11 EDT
Fixed in mod_nss 1.0.11.

Note You need to log in before you can comment on or make changes to this bug.