Bug 862974 - firewall-applet gets AVC denials on "Shields Up"
firewall-applet gets AVC denials on "Shields Up"
Status: CLOSED DUPLICATE of bug 858045
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 01:07 EDT by Ed Greshko
Modified: 2012-10-04 10:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 10:27:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Greshko 2012-10-04 01:07:39 EDT
Description of problem:


Version-Release number of selected component (if applicable): firewall-applet-0.2.8-1.fc18.noarch


How reproducible:


Steps to Reproduce:
1. Start the applet
2. Select "Shields Up"
3. Provide root password
  
Actual results:

type=AVC msg=audit(1349327085.410:336): avc:  denied  { getattr } for  pid=1888 comm="sh" path="/usr/sbin/setfiles" dev="sda3" ino=1451202 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:setfiles_exec_t:s0 tclass=file
type=AVC msg=audit(1349327085.463:337): avc:  denied  { getattr } for  pid=1889 comm="sh" path="/usr/sbin/setfiles" dev="sda3" ino=1451202 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:setfiles_exec_t:s0 tclass=file


Expected results:

No selinux errors


Additional info: According to Daniel Walsh on the test mailing list....

firewalld should not be running setfiles, or restorecon.
Comment 1 Daniel Walsh 2012-10-04 08:52:22 EDT
Why is firewalld running restorecon. If it needs to to fix a label, then it is a bug.  restorecon/setfiles should only be executed by Humans, or init scripts.  Not by running daemons.
Comment 2 Thomas Woerner 2012-10-04 10:27:58 EDT

*** This bug has been marked as a duplicate of bug 858045 ***

Note You need to log in before you can comment on or make changes to this bug.