Bug 863048 - Catalog selection is not getting updated
Catalog selection is not getting updated
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: beta4
: ---
Assigned To: Jiri Tomasek
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 06:21 EDT by Rehana
Modified: 2012-12-04 10:23 EST (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.18-1.el6cf
Doc Type: Bug Fix
Doc Text:
In the Catalog Selection screen, the Catalog displayed "None" by default. This fix now displays "Default" as the default choice.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:23:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog (49.80 KB, image/png)
2012-10-04 06:21 EDT, Rehana
no flags Details
catalog_selection (56.29 KB, image/png)
2012-10-10 20:04 EDT, Shveta
no flags Details

  None (edit)
Description Rehana 2012-10-04 06:21:40 EDT
Created attachment 621551 [details]
catalog

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Login to conductor
2.click on any image
3.Click on "New Application blueprint From image"
4.Select the catalog(PFA:catalog.png)
  
Actual results:
Observed that "None" was displayed even after selecting the catalog name

Expected results:
Should display the catalog name, in case of multiple catalog selection it should display "multiple"

Additional info:
rpm -qa | grep aeolus 
aeolus-conductor-doc-0.13.16-1.el6cf.noarch
rubygem-aeolus-cli-0.7.3-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.8.8-1.el6cf.noarch
aeolus-conductor-0.13.16-1.el6cf.noarch
aeolus-all-0.13.16-1.el6cf.noarch
aeolus-conductor-daemons-0.13.16-1.el6cf.noarch
Comment 2 Angus Thomas 2012-10-04 11:53:08 EDT
The word "None" should not appear at all. That will resolve the issue it not getting correctly updated.
Comment 3 Jiri Tomasek 2012-10-05 08:45:11 EDT
pull request https://github.com/aeolusproject/conductor/pull/102
Comment 4 Tzu-Mainn Chen 2012-10-05 10:40:59 EDT
Pushed to master/1.1:

commit ca4ce32d486cd7db4912a6d9e8718736cda91768
Author: Jiri Tomasek <jtomasek@redhat.com>
Date:   Fri Oct 5 14:24:44 2012 +0200

    BZ863048 New deployable from image catalog list js fix
    
    rails translations can't be used in javascript, so the translation strings
    are passed using data attribute
    (cherry picked from commit f2f7b0a941e8a7f891f1a8b2945d4f3cc0bbbd0c)
Comment 6 Shveta 2012-10-10 20:04:42 EDT
Created attachment 625246 [details]
catalog_selection

Catalog selection gets updated as we choose now.

rpm -qa|grep aeolus
aeolus-conductor-0.13.18-1.el6cf.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-all-0.13.18-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 10:23:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.