Bug 863067 - [MLA] PowerUserRole can't do basic operations with vm
[MLA] PowerUserRole can't do basic operations with vm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Oved Ourfali
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 07:32 EDT by Ondra Machacek
Modified: 2012-10-04 08:41 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 08:41:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (20.93 KB, application/octet-stream)
2012-10-04 07:32 EDT, Ondra Machacek
no flags Details

  None (edit)
Description Ondra Machacek 2012-10-04 07:32:51 EDT
Created attachment 621570 [details]
engine.log

Description of problem:
PowerUserRole can't run/stop vm, which has permissions for.

Version-Release number of selected component (if applicable):
si19.1

How reproducible:
always

Steps to Reproduce:
1. In webadmin as admin create VM.
2. To this VM add 'PowerUserRole' permissions to user 'user'.
3. Login as user 'user' in UserPortal, and try to run VM.
  
Actual results:
User is not authorized to perform this action.

Expected results:
VM should run.

Additional info:
Comment 2 Itamar Heim 2012-10-04 08:41:38 EDT
this is not a bug.
added doc note to make sure this behavior change is documented (though i'm sure we did on the original bug).

power user is a permission to create VMs/disks/nics/templates.
to manage VMs you need the VMAdmin role.

(otherwise, the bug would be opened that power user on cluster is giving the user a permission to all VMs in the cluster, not only the one they created).

Note You need to log in before you can comment on or make changes to this bug.