Bug 863194 - switch to relative mouse movement if app within a guest grabs cursor
switch to relative mouse movement if app within a guest grabs cursor
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-qxl-driver-win (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Alon Levy
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 12:01 EDT by David Jaša
Modified: 2013-05-13 08:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 08:05:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-10-04 12:01:49 EDT
this could be a problem in qxl-win, too because in some circumstances, qxl-win is also able to provide client mouse without agent running.

qxl-win-unsigned-0.1-15


+++ This bug was initially created as a clone of Bug #863186 +++

qxl driver is sometimes able to provide client mouse without agent cooperation so this bug should be handled there, too

xorg-x11-drv-qxl-0.1.0-2.el6


+++ This bug was initially created as a clone of Bug #863179 +++

Description of problem:
switch to relative mouse movement if app within a guest grabs cursor

Version-Release number of selected component (if applicable):
spice-vdagent-0.12.0-1

How reproducible:
always

Steps to Reproduce:
1. make sure that client mouse by agent is in use
2. open a cursor-grabbing app in a guest (another spice-client with server mouse mode, openarena**, ...)
3. grab the cursor
  
Actual results:
the mouse continues to be in absolute mode, making it unusable in both app that grabbed cursor and the rest of the guest

Expected results:
the mouse is switched to relative input mode once an app grabs the cursor and back to absolute when the app releases it

Additional info:
** openarena needs the check for DRI removed in startup script
Comment 1 Alon Levy 2013-05-13 08:05:26 EDT
This is unrelated to qxl-win, the "server mouse without agent" happens only if you have a tablet. Closing as not a bug (leaving bug 863190)

Note You need to log in before you can comment on or make changes to this bug.