Bug 863275 - Bind mounts keep multiplying on named-chroot restart
Bind mounts keep multiplying on named-chroot restart
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 18:43 EDT by Bojan Smojver
Modified: 2013-04-30 19:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 17:30:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2012-10-04 18:43:45 EDT
Description of problem:
As of recently, every time named-chroot gets restarted, there are new bind mounts that pop up on my system. So, today, I have:
--------------------
# mount | grep named
/dev/mapper/vg00-lv00 on /var/named/chroot/etc/named type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/usr/lib64/bind type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/etc/named type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/usr/lib64/bind type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/etc/named type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/usr/lib64/bind type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/etc/named type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/usr/lib64/bind type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/etc/named type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/usr/lib64/bind type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/etc/named type ext4 (rw,relatime,seclabel,data=ordered)
/dev/mapper/vg00-lv00 on /var/named/chroot/usr/lib64/bind type ext4 (rw,relatime,seclabel,data=ordered
--------------------

Version-Release number of selected component (if applicable):
bind-9.9.1-9.P3.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Restart named-chroot service.
2. Watch number of mounts grow.
  
Actual results:
Mounts multiplying.

Expected results:
There should only ever be a couple of them.

Additional info:
Comment 1 Bojan Smojver 2012-10-16 17:30:40 EDT
Cannot reproduce this as of bind-9.9.2-2 (or was it the kernel that fixed it?). Closing.

Note You need to log in before you can comment on or make changes to this bug.