Bug 863311 - [abrt]: WARNING: at fs/btrfs/extent-tree.c:6221 btrfs_alloc_free_block+0x3cb/0x3d0 [btrfs]()
[abrt]: WARNING: at fs/btrfs/extent-tree.c:6221 btrfs_alloc_free_block+0x3cb/...
Status: CLOSED DUPLICATE of bug 951681
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zach Brown
Fedora Extras Quality Assurance
abrt_hash:553e9a2e901e727653995311797...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 00:33 EDT by Joseph Fraser
Modified: 2015-05-17 21:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 15:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Fraser 2012-10-05 00:33:37 EDT
Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.5.5-1.fc17.i686.PAE root=UUID=4dffbb36-4bac-4d96-bc8e-c6f846d845ac ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.5.5-1.fc17.i686.PAE

backtrace:
:WARNING: at fs/btrfs/extent-tree.c:6221 btrfs_alloc_free_block+0x3cb/0x3d0 [btrfs]()
:Hardware name: EP45-UD3R
:Modules linked in: nfsd nfs_acl auth_rpcgss raid456 async_raid6_recov async_memcpy async_pq raid6_pq async_xor xor async_tx fuse lockd ip6table_filter sunrpc ip6_tables ebtable_nat ebtables nf_nat_h323 nf_conntrack_h323 nf_nat_pptp nf_nat_proto_gre nf_conntrack_pptp nf_conntrack_proto_gre ipt_MASQUERADE nf_nat_tftp nf_conntrack_tftp xt_state nf_nat_sip nf_conntrack_sip nf_nat_irc xt_CHECKSUM iptable_mangle nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp iptable_nat bridge stp nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 llc nf_conntrack bnep bluetooth rfkill be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi it87 hwmon_vid lpc_ich r8169 mii vhost_net coretemp mfd_core i2c_i801 tun macvtap macvlan microcode kvm_intel kvm uinput btrfs ata_generic pata_acpi libcrc32c zlib_deflate aacraid pata_jmicron nouveau mxm_wmi wmi video i2c_algo_bit d
:rm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 2166, comm: btrfs-transacti Not tainted 3.5.5-1.fc17.i686.PAE #1
:Call Trace:
: [<c0447ac2>] warn_slowpath_common+0x72/0xa0
: [<f9ef80fb>] ? btrfs_alloc_free_block+0x3cb/0x3d0 [btrfs]
: [<f9ef80fb>] ? btrfs_alloc_free_block+0x3cb/0x3d0 [btrfs]
: [<c0447b12>] warn_slowpath_null+0x22/0x30
: [<f9ef80fb>] btrfs_alloc_free_block+0x3cb/0x3d0 [btrfs]
: [<c095eea4>] ? __wait_on_bit+0x64/0x70
: [<c04fd400>] ? __lock_page+0x80/0x80
: [<f9ee4fcd>] __btrfs_cow_block+0x15d/0x570 [btrfs]
: [<f9ee54c2>] btrfs_cow_block+0xe2/0x230 [btrfs]
: [<f9ee7afb>] push_leaf_left+0xbb/0x140 [btrfs]
: [<f9f2358f>] ? btrfs_item_offset+0xf/0x20 [btrfs]
: [<f9eeabd3>] btrfs_del_items+0x233/0x3a0 [btrfs]
: [<f9efd72b>] btrfs_del_csums+0x25b/0x380 [btrfs]
: [<f9ef0e81>] __btrfs_free_extent+0x681/0x7b0 [btrfs]
: [<f9ef5a2c>] run_clustered_refs+0x3ac/0xa00 [btrfs]
: [<f9f4f3ff>] ? btrfs_find_ref_cluster+0xdf/0x160 [btrfs]
: [<f9ef6202>] btrfs_run_delayed_refs+0x182/0x430 [btrfs]
: [<f9f070f1>] btrfs_commit_transaction+0x81/0x950 [btrfs]
: [<f9f07d8a>] ? start_transaction+0x6a/0x310 [btrfs]
: [<c0467580>] ? wake_up_bit+0x30/0x30
: [<f9f0021d>] transaction_kthread+0x1ed/0x260 [btrfs]
: [<c04727ce>] ? complete+0x4e/0x60
: [<f9f00030>] ? btrfs_destroy_pending_snapshots+0x60/0x60 [btrfs]
: [<c0466e72>] kthread+0x72/0x80
: [<c0466e00>] ? kthread_freezable_should_stop+0x60/0x60
: [<c0968a7e>] kernel_thread_helper+0x6/0x10
Comment 1 Josh Boyer 2012-10-05 08:33:09 EDT
Do you recall what was happening on the machine when this hit?
Comment 2 Joseph Fraser 2012-10-05 20:54:20 EDT
yes 
i was removeing files from the drives with rm -rf /mnt/store/ i think when it got to the end of the subtree it tried to delete the store folder and it spewed that error
Comment 3 Dave Jones 2013-05-15 15:04:09 EDT

*** This bug has been marked as a duplicate of bug 951681 ***

Note You need to log in before you can comment on or make changes to this bug.