Bug 863379 - Not working dc:setup
Not working dc:setup
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta5
: ---
Assigned To: Steve Linabery
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 05:57 EDT by Jaromir Coufal
Modified: 2012-10-16 03:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 15:55:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output of rake dc:steup (34.30 KB, text/plain)
2012-10-05 05:57 EDT, Jaromir Coufal
no flags Details

  None (edit)
Description Jaromir Coufal 2012-10-05 05:57:48 EDT
Created attachment 622072 [details]
Console output of rake dc:steup

Description of problem:
dc:setup doesn't work properly - throws error

Version-Release number of selected component (if applicable):
cloudforms/1.1, upstream/master

How reproducible:
* run rake dc:setup
* error: undefined method `find_by_username' for #<Class:0x00000004f5f1a0>
  
Actual results:
==  RenameUsersLoginToUsername: migrated (0.0019s) ============================

rake aborted!
undefined method `find_by_username' for #<Class:0x00000004f5f1a0>

Expected results:
passed dc:setup
Comment 2 Steve Linabery 2012-10-12 15:55:11 EDT
I cannot reproduce this.

'rake dc:setup' succeeds for me on both master (e551085) and 1.1 (51746ee).

I did:
1) install rpms from aeolus-nightly repo
2) run aeolus-configure
3) clone conductor
4) git checkout master
5) copy database.pg to database.yml
6) mv Gemfile Gemfile.in
7) rake db:create
8) rake dc:setup
9) git checkout 1.1
10) mv Gemfile Gemfile.in
11) rake dc:setup

no errors.

Please provide more detail on how to reproduce if I'm doing something vastly different from you.
Comment 3 Jaromir Coufal 2012-10-15 03:44:54 EDT
I am using bundler:

For 1.1
1) git fetch -all
2) git merge --ff-only cloudforms/1.1
3) git submodule update
-- here I should have the latest version of 1.1
4) for 1.1 I need to use this reference for aeolus-image in Gemfile: https://github.com/aeolusproject/conductor/blob/master/src/Gemfile#L20
(otherwise conductor with bundler doesn't run)
5) bundle exec rake db:drop
6) bundle exec rake db:create
7) bundle exec rake dc:setup
8) ->
rake aborted!
undefined method `find_by_username' for #<Class:0x00000004769590>

For upstream/master
1) git fetch -all
2) git merge --ff-only upstream/master
3) git submodule update
-- here I should have the latest version of upstream/master
(don't need to add reference to aeolus-image, it is already in Gemfile)
4) bundle exec rake db:drop
5) bundle exec rake db:create
6) bundle exec rake dc:setup
7) ->
rake aborted!
undefined method `find_by_username' for #<Class:0x000000059b3ac0>

Hope it helps.
Comment 4 Steve Linabery 2012-10-15 11:59:03 EDT
(In reply to comment #3)
> I am using bundler:
> 
> For 1.1
> 1) git fetch -all
> 2) git merge --ff-only cloudforms/1.1
> 3) git submodule update
> -- here I should have the latest version of 1.1
> 4) for 1.1 I need to use this reference for aeolus-image in Gemfile:
> https://github.com/aeolusproject/conductor/blob/master/src/Gemfile#L20
> (otherwise conductor with bundler doesn't run)
> 5) bundle exec rake db:drop
> 6) bundle exec rake db:create
> 7) bundle exec rake dc:setup
> 8) ->
> rake aborted!
> undefined method `find_by_username' for #<Class:0x00000004769590>
> 
> For upstream/master
> 1) git fetch -all
> 2) git merge --ff-only upstream/master
> 3) git submodule update
> -- here I should have the latest version of upstream/master
> (don't need to add reference to aeolus-image, it is already in Gemfile)
> 4) bundle exec rake db:drop
> 5) bundle exec rake db:create
> 6) bundle exec rake dc:setup
> 7) ->
> rake aborted!
> undefined method `find_by_username' for #<Class:0x000000059b3ac0>
> 
> Hope it helps.

We don't support bundler use in downstream, so this should not be a blocker for downstream. I suggest re-filing this against upstream since it does appear to be broken there.
Comment 5 Jaromir Coufal 2012-10-16 03:28:44 EDT
OK, I will fill it one more time against upstream.

Note You need to log in before you can comment on or make changes to this bug.