Bug 863383 - Instances stuck in "New" status
Instances stuck in "New" status
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity medium
: beta5
: ---
Assigned To: Jan Provaznik
Rehana
: Triaged
: 861408 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 06:08 EDT by Rehana
Modified: 2012-12-04 10:07 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Launching instances using an image in Conductor resulted in the instance status freezing in a "New" state. This was caused by an incorrectly sized column in the database that caused an exception in the rescue block to be raised, preventing the status to change to the "create_failed" state. This update fixes the migration failed state and the status now properly changes to "Create_failed" when the instance fails.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:07:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2012-10-05 06:08:58 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Login to conductor
2.Build,push image to ec2
3.remove ami from EC2 console
4.launch instance using the image on conductor
  
Actual results:
Instance status is stuck in 'New' state

Expected results:
It should go to "create_failed" state

Additional info:
: INSERT INTO "events" ("created_at", "deleted_at", "status_code", "updated_at", "summary", "event_time", "source_type", "description", "source_id") VALUES ('2012-10-05 09:56:25.226744', NULL, 'deployment_launch_failed', '2012-10-05 09:56:25.226744', 'Failed to launch deployment', '2012-10-05 09:56:25.000000', 'Deployment', 'Match not found: jprovazn-ec2-test02/rhel62-rhem: RPrivate_Cloud: Frontend Cloud
Resource Cluster Ecluster is not mapped to an applicable Cloud Resource Provider or Provider Realm, jprovazn-ec2-test02/rhel62-rhem: mock: Cloud Resource Provider must be enabled, jprovazn-ec2-test02/rhel62-rhem: VPrivate_cloud: Image is not pushed to this Cloud Resource Provider Account', 17) RETURNING "id"

on
rpm -qa | grep aeolus
aeolus-conductor-doc-0.13.16-1.el6cf.noarch
rubygem-aeolus-cli-0.7.3-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.8.8-1.el6cf.noarch
aeolus-conductor-0.13.16-1.el6cf.noarch
aeolus-all-0.13.16-1.el6cf.noarch
aeolus-conductor-daemons-0.13.16-1.el6cf.noarch
Comment 1 Jan Provaznik 2012-10-05 06:11:57 EDT
I think we should fix this for 1.1 release. It should be simple
Comment 3 Jan Provaznik 2012-10-05 06:16:20 EDT
this is caused by too short column in DB, and an exception in rescue block is raised (so create_failed state is not set properly.
Comment 4 Dave Johnson 2012-10-08 13:42:08 EDT
*** Bug 861408 has been marked as a duplicate of this bug. ***
Comment 5 Jan Provaznik 2012-10-09 07:27:34 EDT
a patch sent: https://github.com/aeolusproject/conductor/pull/110
Comment 6 Jan Provaznik 2012-10-09 07:31:54 EDT
pushed both to master and 1.1, 1.1 commit is: 7245cbf059eb67e97bf233b39829573522ce5d1c
Comment 8 Rehana 2012-10-18 00:19:29 EDT
Retested, Instance status changed to create_failed

Verified on 

rpm -qa| grep aeolus
rubygem-aeolus-cli-0.7.5-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.20-1.el6cf.noarch
aeolus-all-0.13.20-1.el6cf.noarch
aeolus-conductor-doc-0.13.20-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-daemons-0.13.20-1.el6cf.noarch
Comment 10 errata-xmlrpc 2012-12-04 10:07:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.