Bug 863419 - After some days, my credentials for Google expired. When trying to log in again, nothing happens. This removes some of the Mail, Calendar, etc. config.
After some days, my credentials for Google expired. When trying to log in aga...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 08:37 EDT by HeCSa
Modified: 2013-02-03 16:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-03 16:31:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 660932 None None None 2012-10-15 10:06:30 EDT

  None (edit)
Description HeCSa 2012-10-05 08:37:10 EDT
Description of problem:
After some days, the credentials for my Google account expired. 
When pressing over the "Log In" button, to renew them, nothing happens.
And after this, my Evolution Calendar, Mail, and Contacts, are unconfigured.

Version-Release number of selected component (if applicable):
Fedora 17, x86_64.

How reproducible:
Just wait for the creds to expire

Steps to Reproduce:
1. Configure the accounts.
2. Wait for the credentials to expire.
3.
  
Actual results:
The credentials cannot be renewed.

Expected results:
Credentials to be renewed, or not to expire.

Additional info:
Comment 1 Debarshi Ray 2012-10-15 10:05:22 EDT
Sounds like your computer's clock is not set to the correct time.
Comment 2 HeCSa 2012-10-15 10:33:07 EDT
It seems to me that this is not the case.
The laptop clock is synchronized via ntp, and ntq does not show any considerable delay.
Also, the "date" output show the correct date/time.
Thanks,

HeCSa.
Comment 3 Debarshi Ray 2012-10-15 10:55:34 EDT
If your clock is correct then you should atleast see Google's login page and be able to sign in and allow access? Do you get that?
Comment 4 HeCSa 2012-10-15 16:46:42 EDT
Nope, I don't. When I click the "Log In" button, nothing happens. No login screen, or any other message.
Thanks,

HeCSa.
Comment 5 Debarshi Ray 2012-10-16 08:37:05 EDT
Could you please try out this new gnome-online-accounts package that I built: http://koji.fedoraproject.org/koji/taskinfo?taskID=4591231

Does it throw an error when you click the "Log In" button?
Comment 6 HeCSa 2012-10-17 00:47:57 EDT
Hi, 

I installed the new package for x86_64 arch, and now I'm waiting for the credentials to expire again (in the meantime I deleted the account, and created it again, since I use this laptop for my day job).

If everything goes as the first time, I'll receive a timeout soon.

Something strange is that the use of CPU is higher, the gnome-shell process grew from 5~7% of CPU usage to 17~20%. I'm not saying this new package version has something to do, because I didn't any debug and/or analysis, but if there is somebody else reporting  the same, maybe it's a pattern of something going wrong.

Thanks for the package, your time and attention.

Best regards,

HeCSa.
Comment 7 Debarshi Ray 2012-10-17 12:52:23 EDT
Ok. Looking forward to the outcome. :-)
Comment 8 HeCSa 2012-10-20 11:23:17 EDT
Hi,

Right now, I'm not having a "Credentials expired" message, but I'm receiving a "Network Error" one.
With this message, I have two options: "Reconnect", and "Edit Account". If I choose reconnect, nothing happens. If I choose "Edit Account", the account list appears, but everything seems to be just fine, and online...strange, hahaha...

I don't know if this is the same error with a new face, or a new one :)

Thanks, and best regards,

HeCSa.

Note You need to log in before you can comment on or make changes to this bug.