Bug 863440 - Need note indicating limitation in syncing sha256 RPMs
Need note indicating limitation in syncing sha256 RPMs
Status: CLOSED CURRENTRELEASE
Product: CloudForms Common
Classification: Red Hat
Component: Docs Release Notes (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: beta6
: ---
Assigned To: Julie
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 09:35 EDT by Corey Welton
Modified: 2012-12-10 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:59:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2012-10-05 09:35:03 EDT
Per bug #855146, we currently cannot presently sync sha/sha256 RPMs.  We should indicate this limitation somewhere in the user guide or technical notes or something.

Specifically, see https://bugzilla.redhat.com/show_bug.cgi?id=855146#c7

It would read something to the effect of:

"Note: Due to present limitations in pulp, users will be unable to fully sync repos with RPMs that contains sha/sha256 checksums."


I am not 100% sure if that is technically accurate/complete, however.  Dev could provide better details.
Comment 1 Corey Welton 2012-10-05 09:39:01 EDT
The significance here is that at least a couple well-known third party (VirtualBox, [some?] Google) repos contain these signatures, so it could become a fairly prevalent question.
Comment 3 Mike McCune 2012-10-16 10:54:59 EDT
To be clear, we can only sync SHA-256 style RPMs, it is the older SHA-1 style RPMs we can not sync into Katello.  I'd reword the above statement to state:

"Note: Due to present limitations in the Pulp subcomponent of Cloudforms System Engine, users will be unable to fully sync repositories that contain RPMs built with SHA-1 checksums.  Repositories containing packages built using SHA-256 hashes are able to be synced with full support."
Comment 6 Lana Brindley 2012-12-10 16:59:50 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.