Bug 863494 - root password spoke loses its icon
root password spoke loses its icon
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 11:23 EDT by Reartes Guillermo
Modified: 2014-02-25 15:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 15:03:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot, edited with suggestions (175.39 KB, image/png)
2012-10-05 11:23 EDT, Reartes Guillermo
no flags Details
screenshot showing progress bar while installing software from Live CD (36.90 KB, image/png)
2012-10-06 17:36 EDT, Steve Tyler
no flags Details
screenshot showing console error message: Could not find the icon 'dialog-password-symbolic'. (17.57 KB, image/png)
2012-10-08 14:09 EDT, Steve Tyler
no flags Details
anaconda.log (4.61 KB, text/plain)
2012-10-08 18:12 EDT, Steve Tyler
no flags Details
ifcfg.log (2.61 KB, text/plain)
2012-10-08 18:12 EDT, Steve Tyler
no flags Details
packaging.log (38.39 KB, text/plain)
2012-10-08 18:13 EDT, Steve Tyler
no flags Details
program.log (27.87 KB, text/plain)
2012-10-08 18:13 EDT, Steve Tyler
no flags Details
storage.log (87.65 KB, text/plain)
2012-10-08 18:14 EDT, Steve Tyler
no flags Details
X.log (53.26 KB, text/plain)
2012-10-08 18:15 EDT, Steve Tyler
no flags Details
dmesg.log (36.09 KB, text/plain)
2012-10-08 18:16 EDT, Steve Tyler
no flags Details
F18b TC6 the issue is still there (49.03 KB, image/png)
2012-10-21 11:29 EDT, Reartes Guillermo
no flags Details
screenshot of vt1 (console) (42.89 KB, image/png)
2012-12-15 23:12 EST, Reartes Guillermo
no flags Details
screenshot showing the loss icon (45.01 KB, image/png)
2013-03-23 18:31 EDT, Reartes Guillermo
no flags Details
screenshot showing vt1 output (33.73 KB, image/png)
2013-03-23 18:32 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-05 11:23:56 EDT
Created attachment 622272 [details]
screenshot, edited with suggestions

Description of problem:

In the screen-shot there is a proposal to improve such screen.
This is really an request to improve the screen before final release.

Version-Release number of selected component (if applicable):
F18b TC2

How reproducible:
always

Steps to Reproduce:
1. boot
2. set a root user
3. install
Comment 1 Steve Tyler 2012-10-05 15:42:20 EDT
That's called the "personalization hub" here:

Making Fedora easier to use & the Installer UX redesign
Posted by mairin ⋅ June 16, 2011
http://mairin.wordpress.com/2011/06/16/making-fedora-easier-to-use-the-installer-ux-redesign/

(There are no internal links -- it's about halfway down the page.)

There are some comments on progress bars here:
Anaconda/UX Redesign
https://fedoraproject.org/wiki/Anaconda/UX_Redesign
(A little more than halfway down.)
Comment 2 Chris Lumens 2012-10-06 15:34:12 EDT
Let me address things one at a time here:

(1) It is CONFIGURATION, because on this hub you're supposed to be able to do various configurations things while installation progresses.  We just don't have much there yet, and won't until F19.

(2) Broken icon - Yeah, I don't know what's going on there.  It's definitely supposed to be a little lock icon.  That's what I see here.  Perhaps there's an error message on tty1 about not being able to load an image?

(3) Root password - That's going to end up being required, so I'm not sure your comments apply after that's the case.

(4) Artwork - The space below the progress bar is ready for artwork, just as soon as some is created and shipped with the installation media.  The code's ready.

(5) Progress bar - There's nothing to fix there.  The progress bar moves when major steps are completed, not when individual packages are completed.
Comment 3 Steve Tyler 2012-10-06 17:36:34 EDT
Created attachment 622835 [details]
screenshot showing progress bar while installing software from Live CD

Reartes: Have you tried a Live CD install?

During a Live CD install, the only sign of activity while "Installing Software" is a spinner. A progress bar is not really suited to coarse-grained, discrete, long-running steps. I've seen bullet lists used for this purpose.

The incorrect icon looks and sounds like a bug. If you believe it is reproducible, it would be better to file a separate bug.
Comment 4 Steve Tyler 2012-10-06 18:42:47 EDT
(In reply to comment #3)
...
> The incorrect icon looks and sounds like a bug. If you believe it is
> reproducible, it would be better to file a separate bug.

I see a key icon with the Live CD (as in the attached screenshot) and the net install CD, both running in a VM:

$ qemu-kvm -m 2048 -hda f18-test-3.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC2/Fedora-18-Beta-TC2-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on

$ qemu-kvm -m 1024 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC2/Fedora-18-Beta-TC2-x86_64-netinst.iso -usb -vga qxl -boot menu=on

Haven't tried the DVD ...
Comment 5 Steve Tyler 2012-10-07 14:00:39 EDT
(In reply to comment #3)
...
> During a Live CD install, the only sign of activity while "Installing
> Software" is a spinner.
...

If I'm interpreting the log files correctly, for a test of a Live CD install in a VM, the rsync activity runs for about 6.5 minutes. Couldn't the installer log the major steps that appear in the progress bar in one log file with a consistent tag, so some statistics could be collected?

$ grep rsync *.log | egrep -i 'install|exit'
anaconda.log:20:43:44,539 INFO anaconda: rsync exited with code 23
anaconda.program.log:20:37:13,386 INFO program: Running... rsync -pogAXtlHrDx /mnt/install/source/ /mnt/sysimage
Comment 6 Chris Lumens 2012-10-08 10:45:45 EDT
Putting into needinfo based on my question in point #2 of my comment above.
Comment 7 Reartes Guillermo 2012-10-08 13:42:07 EDT
@Chris Lumens

"(2) Broken icon - Yeah, I don't know what's going on there.  It's definitely supposed to be a little lock icon.  That's what I see here.  Perhaps there's an error message on tty1 about not being able to load an image?"

"Putting into needinfo based on my question in point #2 of my comment above."

Well, i have found how-to trigger it:

* Do your install, once you start installing:

* set a password, for example user=root01 & password=root01

* a yellow banner will appear below, double-click the banner to see
the error / message, then exit from the dialog. 

* Now the broken icon will show up and will remain like that even
when disabling the root password.

F18b TC2 on the same guest.

Not touching the yellow banner leads to normal results.
Comment 8 Steve Tyler 2012-10-08 14:09:32 EDT
Created attachment 623620 [details]
screenshot showing console error message: Could not find the icon 'dialog-password-symbolic'.

Nice work, Reartes. I reproduced the missing key icon with Fedora-18-Beta-TC2-x86_64-netinst.iso. Not precisely sure how ...

$ qemu-kvm -m 1024 -hda f18-test-3.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC2/Fedora-18-Beta-TC2-x86_64-netinst.iso -usb -vga qxl -boot menu=on
Comment 9 Steve Tyler 2012-10-08 18:07:39 EDT
I believe a reproducer is to enter the password spoke, set a 6-character password ("123456"), click done twice, and then repeatedly switch between the configuration hub and the password spoke without making any changes to the password. The incorrect icon appears almost immediately after package installation begins.

Once the incorrect icon is displayed, it remains displayed during installation. Near the end of installation, the correct key icon is again displayed: after bootloader and after creating something I couldn't read.

Testing tips:
1. Start with an empty disk to work around partitioning problems.
2. Do a minimal install (makes turnaround faster).

Tested with:
$ qemu-kvm -m 1024 -hda f18-test-3.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC2/Fedora-18-Beta-TC2-x86_64-netinst.iso -usb -vga qxl -boot menu=on
Comment 10 Steve Tyler 2012-10-08 18:12:29 EDT
Created attachment 623771 [details]
anaconda.log
Comment 11 Steve Tyler 2012-10-08 18:12:59 EDT
Created attachment 623772 [details]
ifcfg.log
Comment 12 Steve Tyler 2012-10-08 18:13:25 EDT
Created attachment 623774 [details]
packaging.log
Comment 13 Steve Tyler 2012-10-08 18:13:53 EDT
Created attachment 623775 [details]
program.log
Comment 14 Steve Tyler 2012-10-08 18:14:27 EDT
Created attachment 623776 [details]
storage.log
Comment 15 Steve Tyler 2012-10-08 18:15:04 EDT
Created attachment 623777 [details]
X.log
Comment 16 Steve Tyler 2012-10-08 18:16:42 EDT
Created attachment 623779 [details]
dmesg.log
Comment 17 Steve Tyler 2012-10-08 18:18:10 EDT
The attached log files are from when installation is complete and the reboot button is sensitive.
Comment 18 Jesse Keating 2012-10-08 22:14:58 EDT
That's actually my spoke, I'll take the bug.
Comment 19 Jesse Keating 2012-10-09 00:43:49 EDT
I can reproduce it too.

(anaconda:781): Gtk-WARNING **: Could not find the icon 'dialog-password-symbolic'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases

Funny thing though, as the file exists.  The icon isn't changing, it's always the same file.  Something screwy is happening to make the icon cache not find it.  Probably going to need some GTK folks to help out with this one.
Comment 20 Reartes Guillermo 2012-10-21 11:29:02 EDT
Created attachment 630918 [details]
F18b TC6 the issue is still there

It performed several installs and this is the first time i see this on F18b TC6, so this appears to happen sometimes (infrequently).
Comment 21 Reartes Guillermo 2012-11-03 16:35:02 EDT
It can also happen with F18b TC7
Comment 22 Reartes Guillermo 2012-12-15 23:12:24 EST
Created attachment 664208 [details]
screenshot of vt1 (console)

I encountered again with anaconda 18.37.2
Comment 23 Reartes Guillermo 2012-12-16 11:37:36 EST
I believe that it is reproducible now if one setups the root password AFTER anaconda started the installation of the packages. If done before, it works ok.
Comment 25 Reartes Guillermo 2013-03-23 18:31:13 EDT
I reproduced it with F19a TC1 (19.12)
Comment 26 Reartes Guillermo 2013-03-23 18:31:48 EDT
Created attachment 715305 [details]
screenshot showing the loss icon
Comment 27 Reartes Guillermo 2013-03-23 18:32:23 EDT
Created attachment 715306 [details]
screenshot showing vt1 output

the file does exists at least.
Comment 28 Samantha N. Bueno 2013-05-07 13:38:17 EDT
Could you verify if this is still an issue in F19beta-TC3?
Comment 29 Samantha N. Bueno 2013-05-14 10:48:29 EDT
F19beta-TC4 is available--would you mind verifying this is still an issue?
Comment 30 Reartes Guillermo 2013-05-14 10:52:33 EDT
I am not sure that it is fixed, i have not seen it in recent times.
In fact, i never saw it with F19b TC4.
Comment 31 Reartes Guillermo 2013-05-26 13:16:06 EDT
I did not see it, currently F19b RC4.

I suggest leaving this bug-report open and close it after F19 Release, if no further sightings of the issue are reported.
Comment 32 Chris Lumens 2014-02-25 15:03:36 EST
No one has seen this for a very long time, so I think it's safe to say it got taken care of.

Note You need to log in before you can comment on or make changes to this bug.