Bug 863538 - Preupgrade from Fedora 17 to Fedora 18 fails
Preupgrade from Fedora 17 to Fedora 18 fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 14:30 EDT by Mildred
Modified: 2013-06-24 06:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-07 13:55:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mildred 2012-10-05 14:30:56 EDT
Description of problem: Preupgrade fails to set up the upgrade process correctly, anaconda fails with bug 861118

Version-Release number of selected component (if applicable):  preupgrade-1.1.10-2.fc17.noarch

How reproducible: always since a week
Steps to Reproduce: 1. Execute preupgrade and reboot
Actual results: Anaconda fails
Expected results: Upgrade to proceed

Note: I ould not find the preupgrade component, so I filed it under distribution.
Comment 1 Joey Boggs 2012-12-07 13:55:40 EST
From: https://fedoraproject.org/wiki/How_to_use_PreUpgrade?rd=PreUpgrade

Preupgrade deprecated for Fedora 18
Preupgrade does not at present and will not ever work for upgrading to Fedora 18, or any version after that. It will be replaced with a new tool. As of October 2012, the only working method for upgrading to Fedora 18 is yum.
Comment 2 vdm 2013-06-24 06:17:36 EDT
http://fedoraproject.org/wiki/Upgrading_Fedora_using_yum/ru
This page now contradicts to previous message!

Russian documentation says that "yum is not recommended way, use PreUpgrade"!
I've just started upgrade using preupgrade and now i'm dead-locked on anaconda graphical startup.

Note You need to log in before you can comment on or make changes to this bug.