Bug 863556 - Error: COMMAND_FAILED: '/sbin/iptables -N FWDO_ZONE_external -t filter' failed: iptables: Chain already exists.
Error: COMMAND_FAILED: '/sbin/iptables -N FWDO_ZONE_external -t filter' faile...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 15:13 EDT by Serge Pavlovsky
Modified: 2013-01-03 14:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-03 14:21:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Serge Pavlovsky 2012-10-05 15:13:56 EDT
Version-Release number of selected component (if applicable):
firewalld-0.2.5-1.fc17.noarch

How reproducible:
# firewall-cmd --get-active-zones
home: p9p1
public: eth1
# firewall-cmd --zone=external --add --interface=ppp0
Error: COMMAND_FAILED: '/sbin/iptables -N FWDO_ZONE_external -t filter' failed: iptables: Chain already exists.
# firewall-cmd --get-active-zones
home: p9p1
public: eth1
# iptables-save | grep FWDO_ZONE_external
:FWDO_ZONE_external - [0:0]
-A FORWARD_ZONES -o ppp0 -j FWDO_ZONE_external
-A FWDO_ZONE_external -p tcp -m tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
:FWDO_ZONE_external - [0:0]
:FWDO_ZONE_external_allow - [0:0]
:FWDO_ZONE_external_deny - [0:0]
-A FWDO_ZONE_external -j FWDO_ZONE_external_deny
Comment 1 Serge Pavlovsky 2012-10-05 15:17:32 EDT
with table names

# iptables-save | egrep '\*|FWDO_ZONE_external'
*nat
*mangle
:FWDO_ZONE_external - [0:0]
-A FORWARD_ZONES -o ppp0 -j FWDO_ZONE_external
-A FWDO_ZONE_external -p tcp -m tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
*filter
:FWDO_ZONE_external - [0:0]
:FWDO_ZONE_external_allow - [0:0]
:FWDO_ZONE_external_deny - [0:0]
-A FWDO_ZONE_external -j FWDO_ZONE_external_deny
Comment 2 Jiri Popelka 2012-10-08 08:46:43 EDT
I'm not able to reproduce this.
Have you maybe somehow customized firewalld, i.e. have you changed anything in /etc/firewalld ?
Comment 3 Serge Pavlovsky 2012-11-23 14:49:44 EST
i can't reproduce it either
Comment 4 Thomas Woerner 2013-01-03 14:21:38 EST
I can not reproduce this also, closing as WORKS FOR ME.

Note You need to log in before you can comment on or make changes to this bug.