Bug 863557 - sdhci: WARNING: at kernel/irq/manage.c:1211 __free_irq+0x93/0x1d0()
sdhci: WARNING: at kernel/irq/manage.c:1211 __free_irq+0x93/0x1d0()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:689401a6602eaa2a01d70f6aa6c...
:
: 894680 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-05 15:15 EDT by David M.
Modified: 2013-07-01 09:09 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 09:09:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David M. 2012-10-05 15:15:19 EDT
Description of problem:
Ran Geany with a .c program opened on an installed SD card.

Closed the laptop lid <Dell Inspiron 910 > and the computer stayed on, but blacked the monitor.

Opened the laptop lid about 30 minutes later, but the SD card was no longer mounted.  Geany tried to save the currently buffered file, but failed, and I got this kernel problem.


Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.0-2.fc18.i686 root=UUID=77efc4e8-5933-455c-ae9f-1161baa998d7 ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 verbose loadinit 3 LANG=en_US.UTF-8 KEYTABLE=us
kernel:         3.6.0-2.fc18.i686

backtrace:
:WARNING: at kernel/irq/manage.c:1211 __free_irq+0x93/0x1d0()
:Hardware name: Inspiron 910
:Trying to free already-free IRQ 16
:Modules linked in: ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat lockd bnep bluetooth iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_realtek snd_hda_intel uvcvideo snd_hda_codec snd_hwdep videobuf2_vmalloc iTCO_wdt videobuf2_memops videobuf2_core snd_seq iTCO_vendor_support videodev snd_seq_device dell_laptop media snd_pcm compal_laptop dcdbas b43 coretemp microcode bcma mac80211 joydev snd_page_alloc cfg80211 snd_timer i2c_i801 lpc_ich jmb38x_ms rfkill snd memstick soundcore uinput mmc_block i915 i2c_algo_bit drm_kms_helper drm r8169 ssb sdhci_pci mii sdhci mmc_core i2c_core video sunrpc
:Pid: 1345, comm: kworker/0:0 Not tainted 3.6.0-2.fc18.i686 #1
:Call Trace:
: [<c043c5a2>] warn_slowpath_common+0x72/0xa0
: [<c04bbb83>] ? __free_irq+0x93/0x1d0
: [<c04bbb83>] ? __free_irq+0x93/0x1d0
: [<c043c673>] warn_slowpath_fmt+0x33/0x40
: [<c04bbb83>] __free_irq+0x93/0x1d0
: [<c04bbd03>] free_irq+0x43/0xa0
: [<f7e7415b>] sdhci_remove_host+0x4b/0x130 [sdhci]
: [<f7c40be1>] sdhci_pci_remove_slot+0x45/0x92 [sdhci_pci]
: [<f7c40c6b>] sdhci_pci_remove+0x3d/0x60 [sdhci_pci]
: [<c069598d>] pci_device_remove+0x2d/0xe0
: [<c0736cdf>] __device_release_driver+0x5f/0xb0
: [<c0736fa4>] device_release_driver+0x24/0x40
: [<c0736826>] bus_remove_device+0xb6/0x110
: [<c07339ea>] ? device_remove_attrs+0x2a/0x60
: [<c0734265>] device_del+0xe5/0x160
: [<c0734301>] device_unregister+0x21/0x60
: [<c06ab997>] ? pci_remove_firmware_label_files+0x27/0x40
: [<c0697a2b>] ? pci_remove_sysfs_dev_files+0xcb/0x110
: [<c068f8b6>] pci_stop_bus_device+0x76/0x80
: [<c06a632c>] acpiphp_disable_slot+0x14c/0x1b0
: [<c06a63bc>] acpiphp_check_bridge.isra.16+0x2c/0xe0
: [<c06dfed2>] ? acpi_get_name+0x3e/0xa9
: [<c06a69c8>] _handle_hotplug_event_bridge+0x2f8/0x470
: [<c06a4f30>] ? acpiphp_unregister_hotplug_slot+0x60/0x60
: [<c04556ae>] ? cwq_activate_first_delayed+0x2e/0x70
: [<c04558a0>] process_one_work+0x120/0x3e0
: [<c0454710>] ? need_to_create_worker+0x10/0x30
: [<c06a66d0>] ? _handle_hotplug_event_func+0x1b0/0x1b0
: [<c04571e1>] worker_thread+0x111/0x3b0
: [<c046762e>] ? complete+0x4e/0x60
: [<c04570d0>] ? manage_workers+0x2a0/0x2a0
: [<c045bbc2>] kthread+0x72/0x80
: [<c045bb50>] ? kthread_freezable_should_stop+0x60/0x60
: [<c09602be>] kernel_thread_helper+0x6/0x10
Comment 1 David M. 2012-10-05 18:09:05 EDT
Correction:  The computer did go into sleep mode when I closed the lid.

When I opened the lid and the computer left sleep mode the SD card was no longer there.  I removed and inserted the card several times, but it did not show up on nautilus.

When I rebooted I could see the card again.

What I didn't do:

 *I didn't check dmesg for messages.
Comment 2 Sergey 2012-10-07 02:16:06 EDT
maybe wakeup after sleep.

Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Josh Boyer 2012-11-13 10:07:32 EST
Are you still seeing this with the 3.6.6 kernel update?
Comment 4 Satish Balay 2012-12-19 19:11:51 EST
Noticed the ABRT message after resume from suspend

Package: kernel
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 5 Satish Balay 2012-12-19 19:25:00 EST
(In reply to comment #4)
> Noticed the ABRT message after resume from suspend
> 
> Package: kernel
> Architecture: x86_64
> OS Release: Fedora release 18 (Spherical Cow)

BTW: this came up with: 3.7.1-1.fc19.x86_64

[11974.896541] smpboot: Booting Node 0 Processor 3 APIC 0x3
[11974.907546] Disabled fast string operations
[11974.917395] bnx2i: CPU 3 online: Create Rx thread
[11974.917420] CPU3 is up
[11974.920609] ACPI: Waking up from system sleep state S3
[11974.966325] thinkpad_acpi: EC reports that Thermal Table has changed
[11974.985322] ------------[ cut here ]------------
[11974.985327] WARNING: at kernel/irq/manage.c:1211 __free_irq+0xa3/0x220()
[11974.985328] Hardware name: 417152U
[11974.985328] Trying to free already-free IRQ 19
[11974.985361] Modules linked in: joydev hid_lenovo_tpkbd fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i nf_conntrack_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 cnic uio cxgb4i cxgb4 nf_defrag_ipv4 ip6table_filter cxgb3i ip6_tables xt_conntrack nf_conntrack cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_hdmi snd_hda_codec_conexant arc4 snd_hda_intel iwldvm snd_hda_codec mac80211 iTCO_wdt snd_hwdep iwlwifi coretemp tpm_tis thinkpad_acpi microcode e1000e iTCO_vendor_support lpc_ich tpm tpm_bios i2c_i801 snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore cfg80211 mei mfd_core nfsd rfkill
[11974.985371]  auth_rpcgss vhost_net tun macvtap macvlan nfs_acl lockd kvm_intel kvm sunrpc binfmt_misc uinput crc32c_intel i915 ghash_clmulni_intel i2c_algo_bit sdhci_pci drm_kms_helper sdhci drm mmc_core i2c_core wmi video
[11974.985372] Pid: 22502, comm: kworker/0:0 Not tainted 3.7.1-1.fc19.x86_64 #1
[11974.985373] Call Trace:
[11974.985378]  [<ffffffff8105e70f>] warn_slowpath_common+0x7f/0xc0
[11974.985380]  [<ffffffff8105e806>] warn_slowpath_fmt+0x46/0x50
[11974.985382]  [<ffffffff810eca23>] __free_irq+0xa3/0x220
[11974.985384]  [<ffffffff810ecbf4>] free_irq+0x54/0xc0
[11974.985389]  [<ffffffffa00a2820>] sdhci_remove_host+0x60/0x160 [sdhci]
[11974.985394]  [<ffffffffa0020c92>] sdhci_pci_remove_slot+0x3e/0x8b [sdhci_pci]
[11974.985397]  [<ffffffffa0020d2d>] sdhci_pci_remove+0x4e/0x78 [sdhci_pci]
[11974.985402]  [<ffffffff81314eaf>] pci_device_remove+0x3f/0x110
[11974.985406]  [<ffffffff813d28dc>] __device_release_driver+0x7c/0xe0
[11974.985408]  [<ffffffff813d2c1c>] device_release_driver+0x2c/0x40
[11974.985410]  [<ffffffff813d237e>] bus_remove_device+0xee/0x160
[11974.985412]  [<ffffffff813cf7aa>] device_del+0x12a/0x1b0
[11974.985414]  [<ffffffff813cf852>] device_unregister+0x22/0x60
[11974.985416]  [<ffffffff8130eb04>] pci_stop_bus_device+0x94/0xa0
[11974.985418]  [<ffffffff8130ec66>] pci_stop_and_remove_bus_device+0x16/0x30
[11974.985421]  [<ffffffff81326996>] acpiphp_disable_slot+0xf6/0x1b0
[11974.985423]  [<ffffffff81325542>] ? get_slot_status+0x92/0xc0
[11974.985425]  [<ffffffff81326a7d>] acpiphp_check_bridge.isra.14+0x2d/0xf0
[11974.985427]  [<ffffffff8132713b>] _handle_hotplug_event_bridge+0x36b/0x4d0
[11974.985430]  [<ffffffff8107c769>] ? queue_work+0x19/0x20
[11974.985433]  [<ffffffff8117fae9>] ? kfree+0x49/0x170
[11974.985436]  [<ffffffff813478df>] ? acpi_os_release_object+0xe/0x12
[11974.985438]  [<ffffffff8107a557>] process_one_work+0x147/0x490
[11974.985439]  [<ffffffff81326dd0>] ? _handle_hotplug_event_func+0x1d0/0x1d0
[11974.985441]  [<ffffffff8107cdee>] worker_thread+0x15e/0x450
[11974.985443]  [<ffffffff8107cc90>] ? busy_worker_rebind_fn+0x110/0x110
[11974.985445]  [<ffffffff81081d50>] kthread+0xc0/0xd0
[11974.985448]  [<ffffffff81010000>] ? ftrace_raw_event_xen_mmu_flush_tlb_others+0x50/0xe0
[11974.985449]  [<ffffffff81081c90>] ? kthread_create_on_node+0x120/0x120
[11974.985452]  [<ffffffff8163d92c>] ret_from_fork+0x7c/0xb0
[11974.985453]  [<ffffffff81081c90>] ? kthread_create_on_node+0x120/0x120
[11974.985454] ---[ end trace 525dfd8a1a70d6f3 ]---
Comment 6 Josh Boyer 2013-01-14 10:05:33 EST
*** Bug 894680 has been marked as a duplicate of this bug. ***
Comment 7 Hebner Correia 2013-01-30 14:27:32 EST
perl-CPAN-1.9600.01-219.fc17.noarch requer perl = 4:5.14.3-219.fc17
perl-ExtUtils-Install-1.56-219.fc17.noarch requer perl = 4:5.14.3-219.fc17
1:perl-Digest-SHA-5.61-219.fc17.i686 requer perl = 4:5.14.3-219.fc17
perl-Test-Harness-3.23-219.fc17.noarch requer perl = 4:5.14.3-219.fc17
4:perl-devel-5.14.3-219.fc17.i686 requer perl = 4:5.14.3-219.fc17
1:perl-ExtUtils-ParseXS-2.2210-219.fc17.noarch requer perl = 4:5.14.3-219.fc17
perl-Test-Simple-0.98-219.fc17.noarch requer perl = 4:5.14.3-219.fc17


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Anurag 2013-03-09 10:26:53 EST
I was just trying to set up an account in gwibber that's the point when this problem happened

Package: kernel
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 9 John 2013-03-17 22:32:42 EDT
I was relogging in after suspending the session by closing my laptop.

Package: kernel
Architecture: x86_64
OS Release: Fedora release 18 (Spherical Cow)
Comment 10 Josh Boyer 2013-07-01 09:09:54 EDT
There have been no additional reports since march.  We're closing this bug out for now.  If you're still seeing this issue, please reopen.

Note You need to log in before you can comment on or make changes to this bug.