Bug 863565 - Subscription Registration Doesn't Give Focus to Login Field
Subscription Registration Doesn't Give Focus to Login Field
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
IDM QE LIST
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-10-05 15:48 EDT by Matt Reid
Modified: 2013-01-07 23:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:04:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Keyboard focus defaults to the Login field. (24.83 KB, image/png)
2012-10-12 17:08 EDT, John Sefler
no flags Details
Keyboard focus defaults to the Login field. (firstboot) (107.50 KB, image/png)
2012-10-12 17:29 EDT, John Sefler
no flags Details

  None (edit)
Description Matt Reid 2012-10-05 15:48:54 EDT
Description of problem:
When we move to the Subscription Registration credentials section, we don't give focus to the Login field, the user has to tab or click on it before they can start typing. We should give the field focus when we show that dialog so that the user can instead just start typing, hands planted firmly on the keyboard.

This definitely affects firstboot, but it may affect the dialog when launched from the GUI as well.

This gets a little tricky, since we seem to preserve cursor position between screens during the same session, so you have to close it out and start over to try it fresh.
Comment 1 RHEL Product and Program Management 2012-10-05 15:58:15 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Matt Reid 2012-10-05 16:15:17 EDT
Forgot to include this is with a build from today in both RHEL 5 & 6:
subscription-mananger-1.1.2-1.git.74.70cdd3c
Comment 3 Alex Wood 2012-10-09 10:11:09 EDT
commit 1802c16aa7dcb5f96cbf04db959b02fcf5bd0611
Comment 5 John Sefler 2012-10-12 17:08:29 EDT
Created attachment 626290 [details]
Keyboard focus defaults to the Login field.

Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.0.22-1.el5

From within the subscription-manager-gui, manual testing proved that every time the credentials dialog is now opened, the focus goes to the Login: field.  If the entered credentials are bad, then this dialog is re-opened with the user's entered data and the Login field is given focus with the value selected.
Comment 6 John Sefler 2012-10-12 17:29:46 EDT
Created attachment 626299 [details]
Keyboard focus defaults to the Login field. (firstboot)

Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.0.22-1.el5

From within subscription-manager-firstboot, manual testing proved that every time the credentials firstboot panel is now opened, the focus goes to the Login: field.  If the entered credentials are bad, then the focus returns to the Login field with the value entered by the user in a selected state.
Comment 8 errata-xmlrpc 2013-01-07 23:04:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.