Bug 863681 - f18b tc2 anaconda "installation options" dialog is different on some guests (the old one appears)
f18b tc2 anaconda "installation options" dialog is different on some guests (...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 11:36 EDT by Reartes Guillermo
Modified: 2012-10-06 18:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 18:51:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of both guests showing different dialog (466.26 KB, image/png)
2012-10-06 11:36 EDT, Reartes Guillermo
no flags Details
btrfs-1 guest (old dialog) anaconda.log (2.02 KB, text/plain)
2012-10-06 11:37 EDT, Reartes Guillermo
no flags Details
btrfs-1 guest (old dialog) program.log (17.68 KB, text/plain)
2012-10-06 11:37 EDT, Reartes Guillermo
no flags Details
btrfs-1 guest (old dialog) storage.log (45.02 KB, text/plain)
2012-10-06 11:38 EDT, Reartes Guillermo
no flags Details
btrfs-1 guest (old dialog) syslog (68.13 KB, text/plain)
2012-10-06 11:38 EDT, Reartes Guillermo
no flags Details
btrfs-1 guest (old dialog) X.log (55.70 KB, text/plain)
2012-10-06 11:39 EDT, Reartes Guillermo
no flags Details
FFRAWH-2 guest (new dialog) anaconda.log (2.02 KB, text/plain)
2012-10-06 11:40 EDT, Reartes Guillermo
no flags Details
FFRAWH-2 guest (new dialog) program.log (34.17 KB, text/plain)
2012-10-06 11:40 EDT, Reartes Guillermo
no flags Details
FFRAWH-2 guest (new dialog) storage.log (72.01 KB, text/plain)
2012-10-06 11:41 EDT, Reartes Guillermo
no flags Details
FFRAWH-2 guest (new dialog) syslog (64.26 KB, text/plain)
2012-10-06 11:41 EDT, Reartes Guillermo
no flags Details
FFRAWH-2 guest (new dialog) X.log (55.70 KB, text/plain)
2012-10-06 11:42 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-06 11:36:22 EDT
Created attachment 622738 [details]
snapshot of both guests showing different dialog

Description of problem:

I have these guests:

* guest #1 "BTRFS-1" (3x SATA disk 9.5gb) (SPICE/QLX)
* guest #2 "FFRAWH-2" (1x IDE disk 9.7gb) (SPICE/QLX)

Both use the same iso, F18b TC2 (both anacona 18.12)

On both guests:

Select default "engish" & "accept fate"
Enter Storage:Installation Destination
Select one disk in each guest, then continue.
The "installation Options" dialog is diffent in each host!!!

For some reason BTRFS-1 gets the old dialog.

* attached screenshot & /tmp logs of each guest. 

Version-Release number of selected component (if applicable):
F18b TC2 (anaconda 18.12)

How reproducible:
always (on some guests)

Steps to Reproduce:
see above.
  
Actual results:
one guest gets the old dialog, the others the new one.

Expected results:
same dialog on all hosts & guests

Additional info:
Comment 1 Reartes Guillermo 2012-10-06 11:37:18 EDT
Created attachment 622739 [details]
btrfs-1 guest (old dialog) anaconda.log
Comment 2 Reartes Guillermo 2012-10-06 11:37:43 EDT
Created attachment 622740 [details]
btrfs-1 guest (old dialog) program.log
Comment 3 Reartes Guillermo 2012-10-06 11:38:22 EDT
Created attachment 622741 [details]
btrfs-1 guest (old dialog) storage.log
Comment 4 Reartes Guillermo 2012-10-06 11:38:53 EDT
Created attachment 622742 [details]
btrfs-1 guest (old dialog) syslog
Comment 5 Reartes Guillermo 2012-10-06 11:39:24 EDT
Created attachment 622745 [details]
btrfs-1 guest (old dialog) X.log
Comment 6 Reartes Guillermo 2012-10-06 11:40:18 EDT
Created attachment 622746 [details]
FFRAWH-2 guest (new dialog) anaconda.log
Comment 7 Reartes Guillermo 2012-10-06 11:40:44 EDT
Created attachment 622747 [details]
FFRAWH-2 guest (new dialog) program.log
Comment 8 Reartes Guillermo 2012-10-06 11:41:17 EDT
Created attachment 622748 [details]
FFRAWH-2 guest (new dialog) storage.log
Comment 9 Reartes Guillermo 2012-10-06 11:41:48 EDT
Created attachment 622751 [details]
FFRAWH-2 guest (new dialog) syslog
Comment 10 Reartes Guillermo 2012-10-06 11:42:15 EDT
Created attachment 622752 [details]
FFRAWH-2 guest (new dialog) X.log
Comment 11 Chris Lumens 2012-10-06 15:07:31 EDT
There are three different dialogs.  Which one you get depends on whether there's enough free space to install Fedora into or not.  If there is, you don't get the more detailed dialog because it is not required.  Does this match your situation?
Comment 12 Reartes Guillermo 2012-10-06 16:10:57 EDT
@Chris Lumens

Yes, it seems to. BTRFS-1 has free space whereas FFRAWH-2 has not.
I was not aware this was implemented like that, so this can be
closed as NOTABUG safely.

So, dialog #1 is the BTRFS-1 one and dialog #2 is the FFRAWH-2, 
what does the third one says and on which conditions will arise?
Comment 13 Chris Lumens 2012-10-06 18:51:20 EDT
The third one comes up should you not have enough space to do an install, even after making space.  It has the following strings in it:

http://git.fedorahosted.org/cgit/anaconda.git/tree/pyanaconda/ui/gui/spokes/storage.py#n255

Note You need to log in before you can comment on or make changes to this bug.