Bug 863682 - SELinux is preventing /usr/lib64/realmd/realmd from 'getattr' accesses on the file /root/.config/dconf/user.
SELinux is preventing /usr/lib64/realmd/realmd from 'getattr' accesses on the...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5407d2b7fc137634def18f9adad...
:
: 863806 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-06 11:39 EDT by Adam Joseph Cook
Modified: 2012-12-20 10:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:34:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-06 11:39 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-06 11:39 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-06 11:39:16 EDT
Description of problem:
Logged in to GNOME desktop and SELinux raised this issue immediately.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-0.rc7.git1.4.fc18.x86_64

description:
:SELinux is preventing /usr/lib64/realmd/realmd from 'getattr' accesses on the file /root/.config/dconf/user.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that realmd should be allowed getattr access on the user file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep realmd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:realmd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:config_home_t:s0
:Target Objects                /root/.config/dconf/user [ file ]
:Source                        realmd
:Source Path                   /usr/lib64/realmd/realmd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           realmd-0.8-2.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-0.rc7.git1.4.fc18.x86_64 #1
:                              SMP Tue Sep 25 19:55:25 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-06 10:37:13 CDT
:Last Seen                     2012-10-06 10:37:13 CDT
:Local ID                      afb88453-0d19-45e8-a97c-7470a241bb0a
:
:Raw Audit Messages
:type=AVC msg=audit(1349537833.124:151): avc:  denied  { getattr } for  pid=1435 comm="realmd" path="/root/.config/dconf/user" dev="sdb3" ino=1057852 scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349537833.124:151): arch=x86_64 syscall=fstat success=yes exit=0 a0=7 a1=7fff4a30a600 a2=7fff4a30a600 a3=7fff4a30a490 items=0 ppid=1 pid=1435 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=realmd exe=/usr/lib64/realmd/realmd subj=system_u:system_r:realmd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: realmd,realmd_t,config_home_t,file,getattr
:
:audit2allow
:
:#============= realmd_t ==============
:allow realmd_t config_home_t:file getattr;
:
:audit2allow -R
:
:#============= realmd_t ==============
:allow realmd_t config_home_t:file getattr;
:
Comment 1 Adam Joseph Cook 2012-10-06 11:39:18 EDT
Created attachment 622743 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-06 11:39:20 EDT
Created attachment 622744 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:06:55 EDT
*** Bug 863806 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-08 04:14:18 EDT
Fixed in selinux-policy-3.11.1-33.fc18
Comment 5 Fedora Update System 2012-10-11 05:04:00 EDT
selinux-policy-3.11.1-36.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-36.fc18
Comment 6 Fedora Update System 2012-10-11 13:22:35 EDT
Package selinux-policy-3.11.1-36.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-36.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15934/selinux-policy-3.11.1-36.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-12-20 10:34:34 EST
selinux-policy-3.11.1-36.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.