Bug 863806 - SELinux is preventing /usr/lib64/realmd/realmd from 'read' accesses on the file /root/.config/dconf/user.
SELinux is preventing /usr/lib64/realmd/realmd from 'read' accesses on the fi...
Status: CLOSED DUPLICATE of bug 863682
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:39aca1b37f01c2a7ae0c3bf99f7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 10:52 EDT by Adam Joseph Cook
Modified: 2012-10-08 04:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 04:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 10:52 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 10:52 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-07 10:52:20 EDT
Description of problem:
Logged in to GNOME 3 desktop and SELinux raised this issue immediately.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

description:
:SELinux is preventing /usr/lib64/realmd/realmd from 'read' accesses on the file /root/.config/dconf/user.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that realmd should be allowed read access on the user file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep realmd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:realmd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:config_home_t:s0
:Target Objects                /root/.config/dconf/user [ file ]
:Source                        realmd
:Source Path                   /usr/lib64/realmd/realmd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           realmd-0.8-2.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-07 09:50:05 CDT
:Last Seen                     2012-10-07 09:50:05 CDT
:Local ID                      59a491b9-6ac0-4813-9d57-14b41e340958
:
:Raw Audit Messages
:type=AVC msg=audit(1349621405.403:153): avc:  denied  { read } for  pid=981 comm="realmd" name="user" dev="sda3" ino=1057852 scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file
:
:
:type=AVC msg=audit(1349621405.403:153): avc:  denied  { open } for  pid=981 comm="realmd" path="/root/.config/dconf/user" dev="sda3" ino=1057852 scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1349621405.403:153): arch=x86_64 syscall=open success=yes exit=EBADF a0=7f7491b2bd60 a1=0 a2=0 a3=7ffffff06f70 items=0 ppid=1 pid=981 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=realmd exe=/usr/lib64/realmd/realmd subj=system_u:system_r:realmd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: realmd,realmd_t,config_home_t,file,read
:
:audit2allow
:
:#============= realmd_t ==============
:allow realmd_t config_home_t:file { read open };
:
:audit2allow -R
:
:#============= realmd_t ==============
:allow realmd_t config_home_t:file { read open };
:
Comment 1 Adam Joseph Cook 2012-10-07 10:52:22 EDT
Created attachment 622995 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-07 10:52:23 EDT
Created attachment 622996 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-08 04:06:55 EDT

*** This bug has been marked as a duplicate of bug 863682 ***

Note You need to log in before you can comment on or make changes to this bug.