Bug 863813 - Clicking on the abrt-applet notification after an application crash does not immediately invoke abrt-gui
Clicking on the abrt-applet notification after an application crash does not ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 11:32 EDT by Adam Joseph Cook
Modified: 2012-10-22 04:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 04:34:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Joseph Cook 2012-10-07 11:32:00 EDT
Description of problem:
This bug was discovered in response to the Fedora 18 Alpha ABRT Test Day.
http://fedoraproject.org/wiki/Test_Day:2012-10-01_ABRT

Many of the tests - especially this one: http://fedoraproject.org/wiki/QA:Testcase_ABRT in the 'Expected Results' section, claim that an expected result should be that 'clicking on the notification should open abrt-gui'. In my system, this is not the case. Clicking anywhere (besides the 'Ignore' and 'Report' buttons) inside the notification does not do anything but dismiss the notification without bringing up abrt-gui.

If the notification only appears as an ABRT icon in the GNOME 3 'taskbar' (official name??? - the icon tray normally hidden in the lower-right portion of the screen), clicking on the ABRT icon or the notification after clicking the icon simply dismisses the ABRT icon and no abrt-gui appears. The user must then invoke abrt-gui manually.

Clicking on the 'Report' button in the notification window does start the reporting process, but it does not bring up the abrt-gui main window at any time.

This described behavior seems to be different on Fedora 18 then in previous Fedora releases (if my memory serves).

Version-Release number of selected component (if applicable):
abrt-dbus-2.0.14-1.fc18.x86_64
abrt-2.0.14-1.fc18.x86_64
abrt-addon-kerneloops-2.0.14-1.fc18.x86_64
abrt-devel-2.0.14-1.fc18.x86_64
abrt-addon-xorg-2.0.14-1.fc18.x86_64
abrt-tui-2.0.14-1.fc18.x86_64
abrt-retrace-client-2.0.14-1.fc18.x86_64
gnome-abrt-0.2.3-1.fc18.x86_64
rubygem-abrt-0.0.3-1.fc18.noarch
abrt-addon-python-2.0.14-1.fc18.x86_64
abrt-cli-2.0.14-1.fc18.x86_64
abrt-addon-ccpp-2.0.14-1.fc18.x86_64
abrt-desktop-2.0.14-1.fc18.x86_64
abrt-gui-2.0.14-1.fc18.x86_64
abrt-plugin-bodhi-2.0.14-1.fc18.x86_64
abrt-addon-vmcore-2.0.14-1.fc18.x86_64
abrt-libs-2.0.14-1.fc18.x86_64

How reproducible:
Always.

Steps to Reproduce:
http://fedoraproject.org/wiki/QA:Testcase_ABRT
(I crashed both smoltGui and gcalctool during my tests.)
  
Actual results:
abrt-gui does not appear after clicking on the abrt-applet notification.

Expected results:
abrt-gui should appear (per expected results on link above) after the user clicks on the abrt-applet notification.

Additional info:

* Smolt profile:
http://www.smolts.org/client/show/pub_5eda5764-938d-45bb-a643-25f88855c697
Comment 1 Jiri Moskovcak 2012-10-22 04:34:12 EDT
The test case was wrong, it was for the old ABRT version -> fixed.

Note You need to log in before you can comment on or make changes to this bug.