Bug 863824 - can't select location in gnome-shell-extension-weather
can't select location in gnome-shell-extension-weather
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 13:19 EDT by Steevithak
Modified: 2012-10-07 14:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-07 14:49:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steevithak 2012-10-07 13:19:38 EDT
Description of problem:
I installed gnome-shell-extension-weather using yum, turned it on, and restated gnome shell. It appeared on the top toolbar as expected but showed the weather for the wrong location - it didn't even get the country right. So I thought I'd be able to configure the location manually. I clicked the icon in the toolbar and got a dialog which said "weather settings". I deleted the country it had picked in error and then tried to add the correct one. I clicked the plus symbol, then typed the name of my city (Dallas), it showed the entry "Dallas, Texas, US" and dropped that into the Name of City dialog, which has a "Cancel" and "OK" button. However, the entire thing hangs at that point because the "OK" button is greyed out and cannot be clicked. 

There is no error message or explanation of the weird and unexpected behaviour. Since it clearly identified the city and offered a preselected combination, why does it get stuck trying to save it? Like most of GNOME 3, the UI is very non-intuitive. It's not clear if the program is broken, if the user has made a mistake, or if some sort of hidden key-combination is required to proceed further. Very frustrating...

Version-Release number of selected component (if applicable):
gnome-shell-extension-weather-0-0.6.git5be82f2.fc17.noarch

How reproducible:
100% of time on my box

Steps to Reproduce:
1. Install extension
2. See that it selects wrong location
3. Try to manually set correct location

  
Actual results:
Dialog hangs with "OK" greyed out after location is selected

Expected results:
1. Extension needs to do a better job of picking location initially
2. Manual selection of location should be possible.

Additional info:
Comment 1 Mohamed El Morabity 2012-10-07 14:49:02 EDT
gnome-shell-extension-weather is not part of the "official" gnome-shell-extensions pack. It's even not part of the Fedora repositories.

Note You need to log in before you can comment on or make changes to this bug.