Bug 863841 - 'Done' button should not be in the top left corner
'Done' button should not be in the top left corner
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 16:07 EDT by Christoph Wickert
Modified: 2015-01-09 11:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 13:14:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2012-10-07 16:07:51 EDT
Description of problem:
To get back from one of the so called 'spokes' to the 'hub', one has to press the 'Done' button in the top left corner. This position is everything but intuitive, because usually windows are closed with a click on a button at the bottom left. This is both what the GNOME HIG and the KDE design guidelines specify, as well as almost any other OS out there.

Please move the button to the bottom right position so we have a consistent layout with the other buttons like 'Continue', 'Start installation' and 'reboot'. Something, that brings the user to a new screen - and even if it is back to the hub - should always be on the same place.
Comment 1 Elad Alfassa 2012-10-07 16:31:09 EDT
I agree (as a designer who work on some minor parts of the new Anaconda UI).

CC'ing Máirín for further designer feedback.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Chris Lumens 2012-10-08 10:01:41 EDT
Simple as this may seem, I think it's going to require significant enough changes to the widget that we will need to put this off until F19.  I do agree it's a little weirdly positioned (given that we read left-to-right, top-to-button here) but we need to be focusing on bugs, not design changes right now.
Comment 3 Máirín Duffy 2012-10-08 11:34:48 EDT
"usually windows are closed with a click on a button at the bottom left."

can you please point to where you see this in GNOME and the GNOME hig?

I think the button should stay in the upper left. Part of the reason for placing it there is for when you have a non-maximized VM window that you have to scroll down to notice and access the back button on. Some of the screens simply don't have the real estate to have the button anywhere but on the top, where it shares horizontal space with the screen title and the installer identifer.
Comment 4 Christoph Wickert 2012-10-08 11:59:06 EDT
(In reply to comment #3)
> "usually windows are closed with a click on a button at the bottom left."
> 
> can you please point to where you see this in GNOME and the GNOME hig?

Sorry, I meant bottom right. This applies to nearly all windows in GNOME, except main windows, that don't have a way to exit them other than through the menu.

http://developer.gnome.org/hig-book/3.6/windows-utility.html#windows-explicit-apply
http://developer.gnome.org/hig-book/3.6/windows-utility.html#property-windows
http://developer.gnome.org/hig-book/3.6/windows-utility.html#preference-windows
http://developer.gnome.org/hig-book/3.6/windows-alert.html
http://developer.gnome.org/hig-book/3.6/windows-progress.html
http://developer.gnome.org/hig-book/3.6/windows-assistant.html

> I think the button should stay in the upper left. 

I heard somebody form the QA team who said that during the anaconda test day, many people were not even able to find the button there. It was one of the major complaints.

> Part of the reason for
> placing it there is for when you have a non-maximized VM window that you
> have to scroll down to notice and access the back button on. Some of the
> screens simply don't have the real estate to have the button anywhere but on
> the top, where it shares horizontal space with the screen title and the
> installer identifer.

I think we are facing two separate issues here:
1. If the positioning of the button on the bottom of the screen is not consistent, that means reliably at the same spot throughout all windows, then the packaging is wrong.
2. If a user is working with a non-maximized VM-window, how can we make sure he really sees all the settings? He might actually miss something important. We can force him to scroll down (or maximize the window) by placing the button on the bottom.
Comment 5 Máirín Duffy 2012-10-08 12:07:52 EDT
The position of the button is internally consistent. Anaconda is not an application running on top of a full desktop platform. It's a special type of environment and a special case.

Placing the button in the lower left would be very confusing for multi-screen spokes such as the storage spoke, because you proceed through the spoke by hitting the right-most bottom button. if there was additionally a button to go back to the hub (how would you label it? back I guess? then you'd think it went back a screen) to the left of that button, it's really not intuitive whether or not it would lead you back a screen or back completely to the hub.

When you have a hub and spoke model, it's hierarchical, not linear. You go up to back in a hierarchy; you go back or left to go back in a linear feed.

I would be much more concerned about this bug if it was filed during the second or third release of the new installer. You're applying old linear anaconda thinking to something that is not built the same.
Comment 6 Kamil Dudka 2015-01-09 07:48:25 EST
Still a bug in Fedora 21.  Why is this closed?
Comment 7 David Shea 2015-01-09 08:28:50 EST
Please read comment 5 again, which explains why the button is where it is. In Fedora 22 we plan to animate the transitions between hub and spoke so that there is a visible up and down movement between screens. We hope that this will help with this confusion.
Comment 8 Kamil Dudka 2015-01-09 08:42:50 EST
I am afraid that the confusion is elsewhere -- maintainers think that the current placement is correct while users might think it is not.
Comment 9 David Shea 2015-01-09 08:52:53 EST
Please try running Fedora 21 with updates=https://dshea.fedorapeople.org/863841.img. I think you will find it pleasantly elucidating.
Comment 10 Kamil Dudka 2015-01-09 11:12:11 EST
Thanks!  The "Next" and "Begin Installation" buttons in the bottom right corner are definitely much better.  But whenever I open a spoke, the "Done" button is again in the top left corner.  So the problem is fixed only partially.

Note You need to log in before you can comment on or make changes to this bug.