Bug 863865 - SELinux is preventing /usr/bin/netstat from 'search' accesses on the directory net.
SELinux is preventing /usr/bin/netstat from 'search' accesses on the director...
Status: CLOSED DUPLICATE of bug 863864
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-10-07 17:51 EDT by Adam Joseph Cook
Modified: 2012-10-08 04:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-10-08 04:45:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-07 17:51 EDT, Adam Joseph Cook
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-07 17:51 EDT, Adam Joseph Cook
no flags Details

  None (edit)
Description Adam Joseph Cook 2012-10-07 17:51:24 EDT
Description of problem:
1. Attempted to run 'system-config-kdump'.
2. SELinux raised this issue.

Additional info:
libreport version: 2.0.15
kernel:         3.6.0-3.fc18.x86_64

:SELinux is preventing /usr/bin/netstat from 'search' accesses on the directory net.
:*****  Plugin catchall (100. confidence) suggests  ***************************
:If you believe that netstat should be allowed search access on the net directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:allow this access for now by executing:
:# grep netstat /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:Additional Information:
:Source Context                system_u:system_r:kdumpgui_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:sysctl_net_t:s0
:Target Objects                net [ dir ]
:Source                        netstat
:Source Path                   /usr/bin/netstat
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           net-tools-1.60-144.20120917git.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.0-3.fc18.x86_64 #1 SMP Wed Oct
:                              3 13:29:15 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-10-07 16:45:20 CDT
:Last Seen                     2012-10-07 16:45:20 CDT
:Local ID                      be5848a4-a598-47dc-b54b-e35498edd277
:Raw Audit Messages
:type=AVC msg=audit(1349646320.708:197): avc:  denied  { search } for  pid=2676 comm="netstat" name="net" dev="proc" ino=10372 scontext=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=dir
:type=SYSCALL msg=audit(1349646320.708:197): arch=x86_64 syscall=access success=no exit=EACCES a0=7f209d1c0501 a1=4 a2=0 a3=0 items=0 ppid=2675 pid=2676 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=netstat exe=/usr/bin/netstat subj=system_u:system_r:kdumpgui_t:s0-s0:c0.c1023 key=(null)
:Hash: netstat,kdumpgui_t,sysctl_net_t,dir,search
:#============= kdumpgui_t ==============
:allow kdumpgui_t sysctl_net_t:dir search;
:audit2allow -R
:#============= kdumpgui_t ==============
:allow kdumpgui_t sysctl_net_t:dir search;
Comment 1 Adam Joseph Cook 2012-10-07 17:51:26 EDT
Created attachment 623161 [details]
File: type
Comment 2 Adam Joseph Cook 2012-10-07 17:51:28 EDT
Created attachment 623162 [details]
File: hashmarkername
Comment 3 Adam Joseph Cook 2012-10-07 18:10:34 EDT
1. Attempted to run 'system-config-kdump'.
2. SELinux raised this issue.

Package: (null)
OS Release: Fedora release 18 (Spherical Cow)
Comment 4 Miroslav Grepl 2012-10-08 04:45:40 EDT

*** This bug has been marked as a duplicate of bug 863864 ***

Note You need to log in before you can comment on or make changes to this bug.