Bug 863905 - Caught "Database Error" when trying to access drupal and wordpress application.
Caught "Database Error" when trying to access drupal and wordpress application.
Status: CLOSED DUPLICATE of bug 861064
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 23:03 EDT by Yujie Zhang
Modified: 2015-05-14 22:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 09:11:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drupal error (141.92 KB, image/png)
2012-10-07 23:03 EDT, Yujie Zhang
no flags Details
wordpress error (60.38 KB, image/png)
2012-10-07 23:04 EDT, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2012-10-07 23:03:50 EDT
Created attachment 623251 [details]
drupal error

Description of problem:

After I created a drupal application and wordpress application, I tried to access them , but I caught "Database Error".

Version-Release number of selected component (if applicable):
devenv_2295

How reproducible:always


Steps to Reproduce:
1.Go to openshift website and login
2.Create a drupal application and a wordpress application
3.Try to access the applications
  
Actual results:

Caught "Database Error" when tring to access drupal application and wordpress application.
The error message of drupal application is as following:

Error
The website encountered an unexpected error. Please try again later.
Error message

    Notice: Undefined index: OPENSHIFT_DB_USERNAME in include_once() (line 186 of /var/lib/openshift/941db442dde645b4ad112a3f8274fe10/app-root/runtime/repo/php/sites/default/settings.php).
    Notice: Undefined index: OPENSHIFT_DB_PASSWORD in include_once() (line 187 of /var/lib/openshift/941db442dde645b4ad112a3f8274fe10/app-root/runtime/repo/php/sites/default/settings.php).
    Notice: Undefined index: OPENSHIFT_DB_HOST in include_once() (line 188 of /var/lib/openshift/941db442dde645b4ad112a3f8274fe10/app-root/runtime/repo/php/sites/default/settings.php).
    Notice: Undefined index: OPENSHIFT_DB_PORT in include_once() (line 189 of /var/lib/openshift/941db442dde645b4ad112a3f8274fe10/app-root/runtime/repo/php/sites/default/settings.php).
    PDOException: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (13) in lock_may_be_available() (line 164 of /var/lib/openshift/941db442dde645b4ad112a3f8274fe10/app-root/runtime/repo/php/includes/lock.inc).

The error message of wordpress application is as following:

Error establishing a database connection

Details see in attachment.


Expected results:

The drupal application and wordpress applications should be accessed successfully.

Additional info:
Comment 1 Yujie Zhang 2012-10-07 23:04:27 EDT
Created attachment 623252 [details]
wordpress error
Comment 2 Dan McPherson 2012-10-08 09:11:39 EDT

*** This bug has been marked as a duplicate of bug 861064 ***

Note You need to log in before you can comment on or make changes to this bug.