Bug 863996 - Can not connect to postgresql for scalable apps after server upgrade
Can not connect to postgresql for scalable apps after server upgrade
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 05:43 EDT by Jianwei Hou
Modified: 2015-05-14 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-10-08 05:43:38 EDT
Description of problem:
After server upgrade and migration, ssh into scalable apps and type 'psql' to connect to postgresql, it fails

Version-Release number of selected component (if applicable):
On devenv-stage_239

How reproducible:
Always

Steps to Reproduce:
1. Launch an old instance(devevn-stage_239)
2. Create a scalable app and embed postgresql to it
3. Upgrade instance to latest and run migration
4. After migration, ssh into app and connect to postgresql db

  
Actual results:
[perl1s-239u3.dev.rhcloud.com ~]\> psql
psql: could not connect to server: Connection refused
	Is the server running on host "8a64755a0b-239u3.dev.rhcloud.com" and accepting
	TCP/IP connections on port 5432?


Expected results:
Should connect to postgresql successfully

Additional info:
For non-scaling apps, connection to postgresql was successful.
Comment 1 Mrunal Patel 2012-10-08 10:32:33 EDT
Was the hascaledb migration script run?
Comment 2 Xiaoli Tian 2012-10-08 10:55:27 EDT
According to comment https://bugzilla.redhat.com/show_bug.cgi?id=863969#c1,  hascaledb migration script should have been run with the workaround.
Comment 3 Jianwei Hou 2012-10-09 06:20:48 EDT
(In reply to comment #1)
> Was the hascaledb migration script run?

Yes, I have run hascaledb-migrate-2.0.18.rb and I have confirmed it once again.

I can connect to mongodb and mysql successfully, but can't connect to postgresql db
Comment 4 Mrunal Patel 2012-10-09 10:42:00 EDT
Thanks, I will look into migration related bugs today.
Comment 5 Mrunal Patel 2012-10-09 18:50:56 EDT
Fixed with https://github.com/openshift/li/pull/464
Comment 6 Xiaoli Tian 2012-10-09 21:35:53 EDT
(In reply to comment #5)
> Fixed with https://github.com/openshift/li/pull/464

Above pull request has been merged since devenv_2304, move it to ON_QA for verifying.
Comment 7 Jianwei Hou 2012-10-10 01:22:01 EDT
Verified on devenv-stage_239

Steps:
1. Launch an old instance(devevn-stage_239)
2. Create a scalable app and embed postgresql to it
3. Upgrade instance to latest and run migration
4. After migration,run hascaledb-migrate-2.0.18.rb, ssh into app and connect to postgresql db

Result:
Connection was successfully established
[php1s-239u8.dev.rhcloud.com ~]\> psql
psql (8.4.13)
Type "help" for help.

php1s=#

Note You need to log in before you can comment on or make changes to this bug.