Bug 864037 - Re-provisioning machine through Satellite-proxy failed
Re-provisioning machine through Satellite-proxy failed
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
550
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Martin Korbel
: Regression
Depends On:
Blocks: 695276 819027
  Show dependency treegraph
 
Reported: 2012-10-08 08:17 EDT by Martin Korbel
Modified: 2012-12-05 10:02 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-108
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 10:02:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Korbel 2012-10-08 08:17:53 EDT
Description of problem:
Re-provisioning client machines through proxy faild.

Version-Release number of selected component (if applicable):
Satellite - Satellite-5.5.0-RHEL6-re20120911.0
Proxy - spacewalk-proxy-installer-1.7.6-4.el6sat
Client - spacewalk-koan-1.7.1-3.el5sat

How reproducible:
100%

Steps to Reproduce:
1. We have got a synced Satellite, Satellite-proxy registered and activated to satellite, client registered to Satellite-proxy.
2. Create Kickstart profile
3. Schedule re-provisioning client machine
4. rhn_check -vv  (on client)
  
Actual results:
> rhn_check -vv
[...]
- looking for Cobbler at https://<proxy>/cobbler_api
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/koan/utils.py", line 535, in __try_connect
    xmlrpc_server.ping()
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1383, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.4/xmlrpclib.py", line 1137, in request
    headers
ProtocolError: <ProtocolError for <proxy>/cobbler_api: 500 Internal Server Error>
[...]


Expected results:
no traceback and correct re-rovisioning

Additional info:
Comment 5 Jan Pazdziora 2012-11-21 04:14:10 EST
(In reply to comment #0)
> Description of problem:
> Re-provisioning client machines through proxy faild.
> 
> Version-Release number of selected component (if applicable):
> Satellite - Satellite-5.5.0-RHEL6-re20120911.0
> Proxy - spacewalk-proxy-installer-1.7.6-4.el6sat
> Client - spacewalk-koan-1.7.1-3.el5sat
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. We have got a synced Satellite, Satellite-proxy registered and activated
> to satellite, client registered to Satellite-proxy.
> 2. Create Kickstart profile
> 3. Schedule re-provisioning client machine
> 4. rhn_check -vv  (on client)
>   
> Actual results:
> > rhn_check -vv
> [...]
> - looking for Cobbler at https://<proxy>/cobbler_api
> Traceback (most recent call last):
>   File "/usr/lib/python2.4/site-packages/koan/utils.py", line 535, in
> __try_connect
>     xmlrpc_server.ping()
>   File "/usr/lib64/python2.4/xmlrpclib.py", line 1096, in __call__
>     return self.__send(self.__name, args)
>   File "/usr/lib64/python2.4/xmlrpclib.py", line 1383, in __request
>     verbose=self.__verbose
>   File "/usr/lib64/python2.4/xmlrpclib.py", line 1137, in request
>     headers
> ProtocolError: <ProtocolError for <proxy>/cobbler_api: 500 Internal Server
> Error>
> [...]

Could you please provide logs from the Proxy and from the Satellite machine at the time this issue happens? We cannot just blindly revert patches ...
Comment 8 Jan Pazdziora 2012-11-22 03:33:02 EST
Hardcoded URL addressed in Spacewalk master, 6f2380996391a75d6175e385a634370d10da35cc.
Comment 12 Jan Pazdziora 2012-11-26 11:20:17 EST
Fix in Spacewalk master, fb34221c8f5406bc3e260b73f56a4da1ec7b22d0.
Comment 14 Jan Pazdziora 2012-11-26 11:39:55 EST
Fix in Spacewalk master, 90f137650dbb08a68e2857e78f908d376be9e731.
Comment 19 errata-xmlrpc 2012-12-05 10:02:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1544.html

Note You need to log in before you can comment on or make changes to this bug.