Bug 864047 - NFS module problem with Solaris clients after kernel update
NFS module problem with Solaris clients after kernel update
Status: CLOSED DUPLICATE of bug 857525
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: nfs-maint
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 08:43 EDT by Agustin
Modified: 2012-10-17 08:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 08:32:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some logs from the rpcdebug (25.15 KB, text/plain)
2012-10-15 05:27 EDT, Agustin
no flags Details

  None (edit)
Description Agustin 2012-10-08 08:43:08 EDT
- Description of problem:

English is not my native language; please excuse typing errors.

We have this configuration:

NFS Server
----------
OS: Red Hat Enterprise Linux Server release 6.3 (Santiago)
Kernel: 2.6.32-279.9.1.el6.x86_64

NFS Linux Clients
-----------------
OS: Red Hat Enterprise Linux Server release 5.8 (Tikanga)
Kernel: 2.6.18-308.11.1.el5

NFS Solaris Clients
-------------------
OS: Solaris 10 10/09 s10s_u8wos_08a SPARC
Kernel: SunOS 5.10 Generic_147440-23

The home directories are exported via NFS to all clients, which are mounted via automount.

After update the kernel to current version (2.6.32-279.9.1.el6.x86_64) in the NFS server, some applications in "Solaris clients" can`t access to the home directory. For example, Cadence (IC 6.1.5) can't load the libraries (Error-> Work area: can't get working directory) or Pine can't access to any file in home folder. However, no problem from the command line or from Red Hat clients.

If we reboot with old kernel version (2.6.32-220.7.1.el6.x86_64) in the NFS server the problem disappears.


- Version-Release number of selected component (if applicable):

  2.6.32-279.9.1.el6.x86_64

- How reproducible: 
  
  always


Thanks in advance
Comment 2 Jeff Layton 2012-10-08 09:54:48 EDT
Agustin, you'll need to do a bit of work to track down the reason that the solaris clients are having trouble here. Would it be possible for you to open a case with RH support and work with them to diagnose this a bit further?
Comment 3 Agustin 2012-10-09 07:24:16 EDT
(In reply to comment #2)
> Agustin, you'll need to do a bit of work to track down the reason that the
> solaris clients are having trouble here. Would it be possible for you to
> open a case with RH support and work with them to diagnose this a bit
> further?

Well, we have an academic subscription and can't open a case with RH support. We will try to debug the problem. 

Help is always welcome.

Thanks.
Comment 4 J. Bruce Fields 2012-10-09 11:20:55 EDT
My first step would be to attempt to reproduce one of the problems you're seeing while watching the network traffic with wireshark.  Even if you're not an expert on the NFS protocol there may still be some obvious problem (for example, you may see the client attempting some operation and the server returning an error).  It would be useful to know what the problem is.
Comment 5 Agustin 2012-10-15 05:27:06 EDT
Created attachment 627267 [details]
Some logs from the rpcdebug

I have made some tests with Wireshark for the NFS traffic and I cannot find any relevant information for the problem. I have also performed some tests with the debug tool "rpcdebug". This log file contains the results of the command "rpcdebug -m nfsd -s proc fh" in the NFS server when I run some applications in the Solaris clients.

Thanks.
Comment 6 J. Bruce Fields 2012-10-15 12:02:10 EDT
Are you exporting ext4?

If so, does turning off the dir_index feature help?

(unmount, then tune2fs -O ^dir_index /dev/whatever)
Comment 7 Agustin 2012-10-17 04:23:36 EDT
(In reply to comment #6)
> Are you exporting ext4?
> 
> If so, does turning off the dir_index feature help?
> 
> (unmount, then tune2fs -O ^dir_index /dev/whatever)

Ok. We have performed different tests on a nfs test server (exporting a ext4 LV) and we can confirm it does work if we turn off the dir_index feature. The problematic applications in the Solaris clients can access to dir contents.

Now we have to schedule the change in the production server.

Thank you so much.
Comment 8 J. Bruce Fields 2012-10-17 08:32:50 EDT
Note the disadvantage to turning off dir_index is that you may see worse performance on very large directories.

*** This bug has been marked as a duplicate of bug 857525 ***

Note You need to log in before you can comment on or make changes to this bug.